Import contacts from simplified *.csv file only partially working

As preparation for a later, larger import I tried to import a small, super-simple *.csv file.

The sample file I created consists of 4 lines:

Full Name;Email;
fullname1;fullname1@dummy.com;
fullname2;fullname2@dummy.com;
fullname3;fullname3@dummy.com;

When I go through the import wizard and click finally “Resolve fields from the first line” then only the second column is recognized successfully.as email.

On top of the first column still “Unknown (ignore)” is written .

Why?

The column header “Full Name” is exactly written as in a sample export *.csv file.

Consequently the import took place but in all imported contactd lines the “Full Name” column remains empty whereas the emails are shown correctly.

Why?

Peter

Hello Peter,
I just tested CSV file as such:

full name;email;
fullname1;fullname1@dummy.com;
fullname2;fullname2@dummy.com;
fullname3;fullname3@dummy.com;

and the import result was as follows:

Try if changing the first letters to lower case resolves the issue.
Maybe check which encoding you’re using?
Alternatively, you CAN set the column property yourself by clicking the drop-down menu if it’s not recognized automatically.

Regards,
Olivia

Hello Olivia,

thank you for reply.

After trying again a while with solving this problem I found the issue:

The csv file here with the contacts was UTF-8 WITH BOM encoded (and not UTF-8).

After converting the file to UTF-8 (without BOM) it works now.

I would have expected that eMClient pops up in such a case a warning like “import file is not in UTF-8 format”.

Regarding further information about BOM see here:

https://en.wikipedia.org/wiki/Byte_order_mark

Furthermore when importing an UTF-8 with BOM  file NO dropdown element labelled “Encoding” is shown.

Have a look at the attached snapshot.

I think this is a bug.

I would suggest to improve and fix these issues in next version.

Hallo,

bei mir wird nur Fax und E-Mail im Feldtyp erkannt. Groß und Kleine Buchstaben funktionieren auch nicht.
Die CSV hab ich in allen Varianten abgespeichert. Leider ohne Erfolg.

Hat jemand einen Lösung für mich?
Oder müssen englische Wörter in der Kopfzeile verwendet werden?

Gruß Thomas

It doesn’t matter what language the header line words are. Just click the down arrow and select the correct field for that column.

Hallo,

danke für die Antwort.

EM-Client erkennt nur englische Wörter in der Kopfzeile automatisch.
jedes Mal die Felder von Hand zuweisen ist zu aufwendig.

Einige Feldbezeichnungen hab ich gefunden aber leider fehlen noch zwei wichtige Feldbezeichungen

Deutsch = Englisch
Firma = company
Voller Name = full Name
Position = job title
Straße Geschäftlich = work Street
PLZ Geschäftlich = ?
Stadt Geschäftlich = work city
Land Geschäftlich = work country
Telefon Geschäftlich| = work phone
Fax = work Fax
Mobiltelefon = mobile
E-Mail = E-Mail
Webseite = Webpage
Notiz = ?

image

The Notes field is not available as an import option. I opened a support ticket back in January 2020 about this:

They closed the ticket and nothing further has been done about it, even after 15 subsequent releases of versions 7 and 8. I am using an internal build of 8.1 and that field is still missing from the import options. ;-(

Danke das du so schnell geantwortet hast.
Du hast mir sehr geholfen.
danke nochmal.

1 Like