IMAP error

Hallo

I have downloaded emclient for evaluation and I am using it with 2 accounts.

  1. gmail personal account
  2. my office email on godaddy

My email with godaddy works, IMAP settings actually test ok on the diagnostic panel, and mail works, but still I experience every 15 minutes an error from emclient saying “IMAP - An Error attempt to connect to (server) failed. this could be caused by temporary server unavailability or incorrect settings”. I have checked settings, tried with both SSL and not using SSL, different ports, but no way. Can I disable the message, or can you suggest a solution?

thanks

Luca Mangione

Hi,
in the first place please try to change the Security policy to “Use SSL/TLS if available” under the tab IMAP and if it will not help, send us your IMAP logs which will hopefully tell us more. Thank you.

Dear EM Client

ATtached the Log for IMAP account

as you can see there are intermittent issues with the “AD-MYRA” account. It works, but randomly gives connection errors probably on some folders.

Can you pls advise

thanks

Luca Mangione
________________________________________________________

15:26:56 AD-MYRA [IMAP] MailExceptions.ConnectionException:
15:26:56 (Connection terminated)
15:26:56 at MailClient.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
15:26:56 at MailClient.Imap.Synchronizer.SynchronizeFoldersCommand.Execute(WorkerStatus status)
15:26:56 at MailClient.Commands.Command.Process(WorkerStatus status)
_________________________________________________________
AD-MYRA [IMAP] MailExceptions.ConnectionException: Cannot open folder “{0}”.
16:26:57 (Connection terminated)
16:26:57 at MailClient.Imap.ConnectionPoolEntry.SelectFolder(Folder value)
16:26:57 at MailClient.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle)
16:26:57 at MailClient.Imap.ConnectionContext…ctor(ImapAccount account, Folder folder)
16:26:57 at MailClient.Imap.Synchronizer.FolderInfo.CreateConnectionContext()
16:26:57 at MailClient.Imap.Synchronizer.SynchronizeMessagesCommand.Execute(WorkerStatus status)
16:26:57 at MailClient.Commands.Command.Process(WorkerStatus status)
__________________________________________________________
16:26:57 AD-MYRA [IMAP] MailExceptions.ConnectionException: Cannot open folder “{0}”.
16:26:57 (Connection terminated)
16:26:57 at MailClient.Imap.ConnectionPoolEntry.SelectFolder(Folder value)
16:26:57 at MailClient.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle)
16:26:57 at MailClient.Imap.ConnectionContext…ctor(ImapAccount account, Folder folder)
16:26:57 at MailClient.Imap.Synchronizer.FolderInfo.CreateConnectionContext()
16:26:57 at MailClient.Imap.Synchronizer.SynchronizeMessagesCommand.Execute(WorkerStatus status)
16:26:57 at MailClient.Commands.Command.Process(WorkerStatus status)

Hallo AGain

more recent error Log :
_____________________________________________
17:51:56 AD-MYRA [IMAP] MailExceptions.ConnectionException:
17:51:56 (Connection terminated)
17:51:56 at MailClient.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
17:51:56 at MailClient.Imap.Synchronizer.SynchronizeFoldersCommand.Execute(WorkerStatus status)
17:51:56 at MailClient.Commands.Command.Process(WorkerStatus status)
_________________________________________________________________
best

Luca

Please send us also your IMAP logs - go to the menu Tools->Settings->Advanced->Logging and check “IMAP” under the problematic account. Then restart eM Client, try to simulate the issue and send us (with reference to this topic) the logs using the same logging settings window. Thank you.

Hallo

I have already attached IMAP logs above here.

The problem seems to be that after a short time (2-5 minutes) EMclient is not waiting for server response and simply send an error. In outlook there is a specific settings in also already outlined by other user here in the support , see: https://discourse.emclient.com/emclient/to…) where I can adjust timeout serttings and error is resolved. its in “internet email settings > advanced”.

All you need to add to EMclient the ability to do so.

Hope this can be available asap or nat least from v.6

Best

Luca Mangione

Hello,

We have no setting possible for timeout and it is not planned. Anyway we are experiencing problems with GoDaddy mostly because of antivirus software, can you disable AV software at your computer for a while and try eM Client do what you need at that moment?

with regards
Jan

Dear John,

attached is again the logs from emclient as requested.

this time settings work, mail is downloaded but after a while both gmail and my work account do not sync.

I have disabled anti virus but no benefit.

best_

LM
______________________________
16:19:21 chowluca@gmail.com [GData] Synchronizing folder list
16:19:39 chowluca@gmail.com [XMPP] MailExceptions.ConnectionException:
16:19:39 (Unable to read data from the transport connection: An established connection was aborted by the software in your host machine.)
16:19:39 luca.mangione@ad-myra.com [IMAP] MailExceptions.ConnectionException:
16:19:39 (I/O error (stream disposed))
16:19:39 at MailClient.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
16:19:39 at MailClient.Imap.Synchronizer.SynchronizeFoldersCommand.Execute(WorkerStatus status)
16:19:39 at MailClient.Commands.Command.Process(WorkerStatus status)
16:19:42 chowluca@gmail.com [IMAP] MailExceptions.ConnectionException:
16:19:42 (I/O error (stream disposed))
16:19:42 at MailClient.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
16:19:42 at MailClient.Imap.Synchronizer.SynchronizeFoldersCommand.Execute(WorkerStatus status)
16:19:42 at MailClient.Commands.Command.Process(WorkerStatus status)
16:19:43 chowluca@gmail.com [GData] MailExceptions.ConnectionException: Unable to connect to the remote server —> The request ‘Google.Apis.Requests.Request(list @ https://www.googleapis.com/tasks/v1/u…)’ has failed. The service tasks has thrown an exception: Google.GoogleApiRequestException: Unable to connect to the remote server —> System.Net.WebException: Unable to connect to the remote server —> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 173.194.70.95:443
16:19:43 at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
16:19:43 at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
16:19:43 — End of inner exception stack trace —
16:19:43 at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
16:19:43 at Google.Apis.Requests.Request.InternalEndExecuteRequest(IAsyncResult asyncResult)
16:19:43 — End of inner exception stack trace —
16:19:43 at Google.Apis.Requests.ServiceRequest1.EndFetchInternal(IAsyncResult asyncResult) 16:19:43 at Google.Apis.Requests.ServiceRequest1.EndFetch(IAsyncResult asyncResult)
16:19:43 at MailClient.Protocols.Gdata.FetchHelper.FetchWithCancellation[T](ServiceRequest`1 request, CancellationToken cancellationToken)
16:19:43 at MailClient.Protocols.Gdata.TaskFolderSynchronizer.GetFolderList(CancellationToken cancellationToken)
16:19:43 at MailClient.Protocols.Common.FolderSynchronizer.<>c__DisplayClass5.b__0(WorkerStatus status, CancellationToken cancellationToken)
16:19:43 at MailClient.Protocols.Gdata.GenericGapiCommand.Execute(WorkerStatus status)
16:19:43 — End of inner exception stack trace —
16:19:43 at MailClient.Protocols.Gdata.GenericGapiCommand.Execute(WorkerStatus status)
16:19:43 at MailClient.Commands.Command.Process(WorkerStatus status)

Hi,

I think that I might get into problem, but I will need your IMAP logs, Tools - Settings- Advanced, check IMAP under your account, apply and restart eM Client.

Then follow steps which leads to this issue and after that send logs… to galis@emclient.com together with this topic’s url (send those logs by email do not attach them here).

then you can turn logging off.

Jan

Hi John, I am having the exact same problem. Did you guys ever find a solution

Most likely yes, this is usually caused by wrong settings. But that varies with different users.

Could you go to tools - settings - advanced, check SMTP under your account, apply and restart eM Client.
Simulate steps that leads to your issue and after that use “send logs…” to galis@emclient.com together with this topic’s URL in subject.

Then you can turn logging off.

Jan

John,
I just switched back to Outlook while you guys troubleshoot this issue. Its been 3 days and I already hate outlook again. Please advise status of troubleshoot since I am ready to go back to EM client

Hi, please follow my previous answer, but instead of SMTP check IMAP (this was my mistake).

Jan