IMAP: Copy folder does not copy sub-folders

Mac, 8.0.3494, i7 2.6Ghz MacBook Pro.

When I copy a folder (that contains subfolders) from one IMAP account to another IMAP account, em client creates the subfolders on the destination, but does not copy the contents of the subfolder.

If that is expected behavior (I hope not), it would be more intuitive, NOT to create the subfolder either.

I tried to reproduce this but it worked as it should.

Is there a specific email provider who’s IMAP folders do not receive the contents?

I can understand if it is Gmail, because they are not actually folders, just labels that are interpreted as folders. Some users have experienced occasions when moving messages, where the label is completely removed so the message just remains in the All Mail folder.

Thanks for the reply.

It’s a cyrus 2 mail server as the source, and a synology mail server as the destination.

Tried with Thunderbird, works reliably. Tried with emClient various times, always failed. The (sub)folder is there, but it is empty. IIRC those were 2nd level subfolders (subfolder of a subfolder), perhaps that is the issue.

Being your own server, it is difficult for another user to comment or test, unless they also have similar experience with the Synology NAS. I don’t, so will end my comments here.

Sorry I couldn’t be of any help Otto.