imap authentication failure

Hello. Have problem with imap. On Thundrbird this imap settings work good.Please help me to solve this problem. Thanks

* OK [CAPABILITY IMAP4rev1 LITERAL+ ID ENABLE STARTTLS AUTH=SCRAM-SHA-1 AUTH=GSSAPI AUTH=GSS-SPNEGO AUTH=DIGEST-MD5 AUTH=OTP AUTH=NTLM AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN SASL-IR] mail Cyrus IMAP v2.4.17 server ready
A0 CAPABILITY
* CAPABILITY IMAP4rev1 LITERAL+ ID ENABLE ACL RIGHTS=kxte QUOTA MAILBOX-REFERRALS NAMESPACE UIDPLUS NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND BINARY CATENATE CONDSTORE ESEARCH SORT SORT=MODSEQ SORT=DISPLAY THREAD=ORDEREDSUBJECT THREAD=REFERENCES ANNOTATEMORE LIST-EXTENDED WITHIN QRESYNC SCAN XLIST URLAUTH URLAUTH=BINARY STARTTLS AUTH=SCRAM-SHA-1 AUTH=GSSAPI AUTH=GSS-SPNEGO AUTH=DIGEST-MD5 AUTH=OTP AUTH=NTLM AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN SASL-IR COMPRESS=DEFLATE IDLE
A0 OK Completed
A1 STARTTLS
A1 OK Begin TLS negotiation now
A2 CAPABILITY
* CAPABILITY IMAP4rev1 LITERAL+ ID ENABLE ACL RIGHTS=kxte QUOTA MAILBOX-REFERRALS NAMESPACE UIDPLUS NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND BINARY CATENATE CONDSTORE ESEARCH SORT SORT=MODSEQ SORT=DISPLAY THREAD=ORDEREDSUBJECT THREAD=REFERENCES ANNOTATEMORE LIST-EXTENDED WITHIN QRESYNC SCAN XLIST URLAUTH URLAUTH=BINARY AUTH=SCRAM-SHA-1 AUTH=GSSAPI AUTH=GSS-SPNEGO AUTH=DIGEST-MD5 AUTH=OTP AUTH=NTLM AUTH=CRAM-MD5 AUTH=PLAIN AUTH=LOGIN SASL-IR COMPRESS=DEFLATE IDLE
A2 OK Completed
A3 ID (“name” “eM Client” “version” “5.0.18025.0” “GUID” “1”)
A3 NO Only one Id allowed in non-authenticated state
A4 AUTHENTICATE OTP AHN0YW5pc2xhdi5odWRqYWtvdg==
A4 NO authentication failure

Hello,

can I ask you what exactly does your problem do? I mean you can’t receive emails or even add your account into eM Client?

Thank for answer. I can’t add imap account to eM Client, smtp work good. Imap requires login and password and when I enter the correct data, this message popup again.

On diag tab eM Client give me this error for imap - Your credentials have been rejected

In this case, please send me file called “main.dat” which you can find in C:\Users\your name\AppData\Roaming\eM Client

and send it to: galis@emclient.com together with this topic’s address: https://discourse.emclient.com/emclient/to…

regards
Jan

It seems the server rejected the authentication very early, after only the user name was sent. This is pretty unusual server behavior. There may be more information in the server logs and it is possible to disable the OTP authentication scheme in the server configuration.

imap work good on Thunderbird client and Mail on MAC OS. I’ll will chek server setting. thank you for what you’re trying to help

problem is didn’t solved.

When i try to connet from eMclient to imap server (server is don’t use SSL/TLS) but client try login from a encoded connection,and server rejects the request.

P.S. sorry for my english.

server log:
Aug 6 09:37:44 mail cyrus/imap[35002]: starttls: TLSv1 with cipher RC4-MD5 (128/128 bits reused) no authentication
Aug 6 09:37:44 mail cyrus/imap[35002]: badlogin: [10.*.*.*] DIGEST-MD5 [SASL(-13): user not found: unable to canonify user and get auxprops]

From Thunderbird imap auto settings use Port: 143, SSL - STARTTLS, authentication - Kerberos / GSSAPI.

smtp emClient test OK

Hello,

I am very sorry for this delayed response.

We have tried to recreate problem, but since your server is located on inner network we can’t recreate this issue as we need.

If this problem still persist can you try to turn off OTP authentication if it will help?

best regards
Jan