IMAP account failing to edit

Hi - I’m having a lot of trouble with “no authentication” messages from the server on one of my accounts. On checking the account settings I find eM Client is arbitrarily putting in the wrong port for Imap receive. However many times I change it to the correct one (993), it changes back to 143. It also defaults to “force ssl/tls” rather than “use if available”.

I should add that IMAP smtp on the same account allows me to edit the port and security settings without a problem.
Any help out there please?

Try setting it to Port 993 & Use SSL/TLS on Special port (legacy) and save accounts.

Most secure imap account logins use that setting.

Thanks - but that’s my point. I set it exactly as you suggest and eM Client won’t save the change; reverts to its own auto setting of 143.

If it won’t stay saved with any manual setting, and you have already tried removing and re-adding the account via the manual “add account / mail / other” option, then could be you might have a problem with your current eM Client version.

What version of eM Client do you have ?

Also what IMAP mail server are you using ?

I’m using the most current version - downloaded and subscribed from website three days ago. Server is 123-reg, who seem so far to be incapable of solving the problem

Ok. When you manually add the IMAP account via the Add account / Mail / Other option in accounts, just enter the correct settings and “click ignore” on any automatic settings. Then save / finish at the end of the manual account setup.

Then click the IMAP & SMTP tabs and see if its changed. If it does change, correct it & then click "Apply and Save. Then Save & Exit accounts.

Thanks for the help…I can’t get at it until later today but will report back.

Hi…just to report back; I’ve uninstalled, reinstalled, tried em Client, Thunderbird and BlueMail on windows, Android and iOS. I’ve also changed my password (twice) on My Dashboard on the 123-Reg website; and had endless msg exchanges with their help system, including sending screenshots of my settings to them at their request.
I’m on the verge of giving up. Anybody know a decent domain service?