Images not showing in sent emails

I can’t get eM Client to send images that I have pasted in the body of emails. When I open the sent copy the images are gone. I’ve set Gmail to allow images under General settings and I’ve set eM Client to send and receive in html.

Hi David.

When you view the sent message on GMail’s web interface, how does it appear?

If you compose a new message in eM Client, and paste in your image, then close the message and save as a draft. If you open the draft again, is the image still there?

Well, I’ve been playing around with this and conclude that it was a glitch. Maybe I had to restart windows…

BUT, while I’m able to pasted images now, whenever I reply to an email that is clearly html (inbound) there are grid lines in the original message. Seemingly like it was a table, but even the header has grid lines. Exmple attached.


I saw today that email sent to me as a reply lose the images when it gets back to me. It’s a broken link image frame. But the images are appended to a png file. I don’t want a file, I want the images in the body of the email.

It would seem strange that this was something wrong with eM Client. It has to be some setting…

Please take a look:

From your post above with the grid lines, I saw something like this before and it was apparently caused by a database error. This might be the cause of your recent post with the missing images in replies as well.

It is a chore, but you might want to close eM Client and run C:\Program Files (x86)\eM Client\DbRepair.exe. See if that makes any difference. Otherwise deleting the database and starting again may be an option. To delete the database, close eM Client, and then delete or rename C:\Users[username]\AppData\Roaming\eM Client. You may have to show hidden items in Explorer to do that. If you have local data or are using POP3, you will need to export your data before you do that.