Images always showing up

I just installed emClient.  I have version 6.0.21040.0 which is the latest.  When I view emails and/or new email messages arrive, all images are displayed.  I believe this is controlled by Tools>Settings>Mail>Privacy options.  I have Block unsafe content… specified.

How do I set it so that images are only displayed/downloaded if I specifically ask for them?  I believe this may be an issue/bug.  Other posts indicates some users have issues displaying images while mine is the opposite.  I didn’t find any similar to my issue.

Thank you

Hi Vincent, the privacy setting to show unsafe content only works for messages that include an external content, e.g. the image is stored on an external server and not included in the message itself. If you’ve received a message containing an image that was included/attached to the message it will always be displayed, you can not disable showing of these images (the image can also either be inline and is shown between the text, or is included as an attachment, that way it will be downloaded after you open it and shown at the end of the message).

If you want to be prompted to download external content in messages please set the privacy setting in Tools > Settings > Mail > Privacy, and use the recommended setting.

Hope this helps,
Paul.

That could explain it.  However, when I view the mail source of emails that I thought should not be displaying images, I don’t see embedded images but references to images (i.e. URLs/hrefs).  There is no multi-part section with the image data.  Seems like an issue.

Is there a way to turn off all images until I specifically ask to display them?  Oops…you already said there wasn’t.  I guess that would be a feature request :slight_smile:

Hi Vincent, as I previously noted the option to view referenced images is under Tools > Settings > Mail > Privacy and it is the recommended setting.
This setting will prompt you everytime external content needs to be downloaded unless you use the “Always download images from this sender” option.

The option will prompt you to download images only if they are not on your whitelist, to edit your whitelist and possibly remove the sender for which images are automatically downloaded.

Thank you,
Paul.

My whitelist is empty and I do have “Block unsafe content except when from whitelist senders (recommended)” selected in my Mail Privacy setting.

Here’s an example of the issue.  When receiving the email for the comment/reply on this thread, I see an image for the avatar.  I don’t expect to see that image.  I expect a placeholder an the option to download the image, as I have seen in Outlook.  When I View the Mail Source, I see this reference for the image:

3D"User_default_medium"https://dwxmyiyf7jg6.cloudfron=t.net/_cb/13ec386/assets/user_default_medium.png"; style=3D"width:100%; max-=
width:75px; -moz-border-radius: 5px; -webkit-border-radius: 5px; border-rad=
ius: 5px; -khtml-border-radius: 5px;" width=3D"55" />

This has the image source as https://dwxmyiyf7jg6.cloudfront.net/_cb/13ec386/assets/user_default_medium.png which is definitely not in my whitelist, yet I see the image.

It sounds like I shouldn’t be seeing the image.  Is it correct that I am seeing the image?

Hi Vincent, please navigate to the privacy setting in Tools > Settings, and try to clean the whitelist on your computer, wait until you receive another message with external content and please make a screenshot of the received message, and forward the message as attachment to my email mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul.

OK, testing now.

Same issue here. External images loaded anyway even if privacy is set to “block unsafe content”.

The whitelist is empty.

This is basically a show stopper for me.

Hi Matt, are you completely sure the images are linked from another website, can you please send me an example of such email to mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul.

just sent you an email. thanks for the super fast reply

Ya, it’s downloading the linked messages in mine as well. Even so, why is there no option to not show any messages at all for untrusted senders, linked or embedded? There is certain spam that I’d rather not see at all.