Icon on taskbar is only the white letter icon from Windows

Hi!

Since a few days the eM Client Icon on the taskbar is missing. I’ve fixed in to the taskbar and there’s only the standard Windows icon with the white letter.

So i tried to fix this problem with a reinstall, but it doesn’t work.

I 've emtpied the cache folder, too.

Do you have an idea what i can do?

1 Like

Hello,
Have you tried restarting your PC (full restart)?

In the meantime i restarted the system a several times.

If the program is open, in the taskbar is the normal bar. But in that moment i minimize the program to the systray, i’ve get the white letter icon.

Is it possible to get a screenshot?

Just the taskbar area, not the whole screen. :wink:

Normally you just right click on the white task bar icon and remove and then click start and scroll down to eM Client on the apps list and right click add to taskbar and then drag it where u want it.

Have any of the other taskbar icons turned white ?

If other ones have also gone white, could be the eg: Windows theme has accidentally changed. Maybe try resetting the same theme by changing to a different theme in Windows & then changing back again.

I have the same issue. I used EM at windows 10, the switched to Outlook for a while and updated to Windows 11. Now took the EM back in use, the icon is just blank paper. IF you unpin the running client, the icon restores back to normal but once you pin it, the icon dissappears.

All up-to-date, registry checked, several reboots etc. Also tried the repair install of EM but no help.2022-01-05 09_59_35-

miércoles 05 enero 2022 :: 0938hrs (UTC +01:00)

Hi @SirRahikkala

We had a similar issue, without the steps you made to upgrade to Windows 11,
we have a clean install of Windows 11 followed by eMC 8.2.1659.

To get the icon to display correctly we needed to:
1./ First pin to Start
2./ Then pin to Taskbar - from Start icon
3./ From icon on Taskbar ->Properties ->Change Icon ->Reselect Icon ->OK ->Apply (now works OK)
4./ We also ‘Run as Administrator’ on test machine
5./ There is no guarantee this will work for you - but it is worth a try
6./ As @cyberzork suggests you should also maybe change back and forward your Windows 11 Theme.

We do NOT believe it is an issue with eMC as there have been similar instances with other icons.

Sorry I can not tell you which they are as the colleague running the test computer is on leave until 17 January plus he is in Valencia and I am in Sevilla - nobody else has access to the particular laptop - there is a policy of non contact while on leave unless critical and this certainly is not critical.

¡Saludos desde la soleada Sevilla España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

1 Like

Hey,

Thanks for the tip but that does not help. The icon from the properties is selected already and even if I browse again for the correct icon, it does not appear.

miércoles 05 enero 2022 :: 1022hrs (UTC +01:00)

Hi @SirRahikkala

Have you tried as @cyberzork suggests you should also maybe change back and forward your Windows 11 Theme?

To bring you up to date…
I have just spoken with our head Tech colleague, he is aware of the icon issue but not involved, apparently it only happens on some computers.
They are running tests of Windows 11 on 5 other computers (none with eMC), two of them have the issue
(no attempt has been made at correction) 3 do not.
It is concluded that the issue is some sort of random conflict between Windows 11 and unspecified software with the approach at the moment ‘to wait and see’ as there is no intention of a move to Windows 11 for probably about 6 months, and even then it will be phased.
Apparently, (I no longer have regular contact, only attend for specific meetings so I am not completely up to date with developments), none of our client companies have officially moved to Windows 11 and have no plans to do so in the immediate future - some are running their own test of Windows 11.

¡Buena suerte!

¡Saludos desde la soleada Sevilla España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Changing theme did not help either.

Ok, I have solved this. Here are the instructions.

  1. WIN+R opens the run prompt, put in %appdata%

  2. From that location, browse one step back from “Roaming” and open “Local”.

  3. From Local folder, delete the IconCache file and restart the computer.

2 Likes

I’ve tried to delete all icon-cache, but for me it doesn’t work.

I had to reinstall a whole system backup. First i thought there’s a problem with the december update of emClient. But now there’s no problem with the taskbar icon.

Only with the icon in the systray. It doesn’t disappear after closing the program. I have to go with the cursor over the icon.