iCloud Sent mail - not syncing

I can’t get the Sent mailbox for my iCloud to sync up - I looked at these threads, which seems to suggest the solution, but I can’t add any Special Folders in my IMAP section - there just isn’t an option for them.

I have the same problem with emClient 8 and iCloud. emCient does not access iCloud’s Sent folder, instead generating another Sent folder (same name as iCould’s own!!). this client is becoming more and more frustrating. How is such a thing even possible? All other alternatives to Apple Mail i have tried and such low-level errors simply do not happen. Perhaps this product is not ready for the market yet and should be classified as Beta. I am frustrated and about to abort my emClient experiment for good.

Hello – thank you for explaining this, it works.

Hi, I have the same problem: can’t sync Sent messages with ICloud. How did you fix this?

thanks,

Please send an email from eM Client using the iCloud account.
Then login to the iCloud webmail interface.

Is the sent item there?

How is the account setup in eM Client. If you go to Menu > Accounts, do you have an IMAP or POP3 tab?

Hi Gary,

thanks for your help.
I found the sent email on a different folder also named “Sent”.
I have an IMAP tab.

So you have 2 sent folders?

Is this in webmail or in eM Client?

I just checked again, this is what I have:
In Webmail: two “Sent” folders
In eM Client: one “Sent” and one “Sent Messages” folder.

The “Sent Messages” folder on eM Client appears to be syncing with the original (correct) “Sent” folder on webmail.
Can I make eM Client save sent messages on the “Sent Messages” folder?

Thanks again!

Yes.

Go to Menu > Accounts and click on the IMAP tab for this email account.
In the Special Folders section, untick "Automatically detect . . . " and change the Sent folder to Sent Messages.

If that doesn’t work, you will need to ask the email provider for the correct server name for that folder and use that. Unlikely but as an example it may be something like Inbox.SentMessages

2 Likes

That works just fine. Thanks a lot!