Icloud problems again

After working for quite some time eM Client is telling me that my icould credentials are being rejected by the server. I’ve already recreated the app specific password multiple times and it just wont take it. Not sure what else to do. I am able to to access my iCloud mail and CalDAV via other apps without any issue still.

After working for quite some time eM Client is telling me that my iCloud credentials are being rejected by the server. I’ve already recreated the app specific password multiple times and it just wont take it.

I am able to to access my iCloud mail and CalDAV via other apps without any issue still

Might be then your mail authentication method setup and / or CalDAV address settings in eM Client.

What’s your iCloud account IMAP Mail Tab settings & CalDAV Tab iCloud address. Eg: Server address, port, security policy & CalDAV address. Blank out your u/p.

Also have you tried removing and re-adding your account to see if that fixes. If you haven’t, suggest to try that incase or a corrupted acct. eM Client iCloud setup support page. https://www.emclient.com/em-with-icloud

Also have you tried generating a new app password via your apple account. If you haven’t suggest to try that. As might just need a new one for eM Client to authenticate.

Note: Each client normally needs “it’s own separate app generated password”, so could be you are using an app password “that was already used”.

Also if you changed your Apple ID password, you have to generate “all new app passwords for each client” or they will fail.

Lastly you might possibly be using an older version of eM Client that might need an update. You can check for the latest versions for PC & Mac via the release history page.

Note: If you do try removing and re-adding your iCloud account or updating to a later client, backup first via "Menu / Backup incase you need the restore. You can see when the backup is complete via Menu / Show Operations via the dropdown next to Refresh at the top left.

Hi @cyberzork. Thanks for the detailed reply!

I’m not in front of that computer to show you the settings but I will add another post later with that info. For what it’s worth, I’ve tried all the settings.

In regard to your other suggestions, the first time this happened to me I was only able to resolve it by deleting the account and re-adding it as you describe. That worked for a while and now it became an issue again. I did this process again including a new iCloud app specific password and that seems to resolve it. I am working with the latest release of eMClient. It’s rather frustrating and time consuming to have to do this, twice now, to resolve this specific issue in the somewhat short time I’ve used the application.

I also have been getting another error that may or not may not be related. The error I get says that it was unable to upload some specific calendar items and asks me to either delete or ignore. None of the noted calendar items are new or were being edited in any way prior to this. No matter my choice between delete or ignore those calendar items get duplicated in eMClient. I do not see these duplicates on any other device accessing the same calendar. They never go away unless I manually delete them, which is difficult to do as there doesn’t seem to be any way to tell which one to keep. The only way to resolve them is to again delete the account and re-add it. This I’ve also done twice now. In fact it happened shortly after fixing the original issue.

I’m feeling like it’s difficult to rely on eMClient.

Hi @doubledge I’ve been having this intermittent problem too. I did refresh the app specific password at appleid.com but what seemed to work was changing the smtp server security policy to "force usage of SSL/TLS.

Yes, the port and security policy are specific pairs.

So:

Port 587 = Force usage of SSL/TLS
Port 465 = Use SSL/TLS on special port (legacy)

It won’t work with the wrong combination.