iCloud calendar Attachments not working

I am using an iCloud calendar that is shared to me by someone else. I can log in to my account on iCloud.com and upload attachments, but any attachments added through eM Client do not get uploaded. I get a message that says “Forbidden”. I am able to access attachments that are already uploaded to the calendar.

Hello, thank you for reporting this, I was able to replicate this issue and I’ve reported the issue to the developers for more information and a possible solution for this issue. I’ll let you know as soon as we get more information about this problem.

What version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About?

Thank you,

The version is 6.0.22344.0

Hello, can you please try to update to this release and check if the issue persists? 6.0.22774.0

Thank you,

OK, I tried this updated version and here is what I found:

I no longer get the “Forbidden” error message in eM Client, but the attachments are still not working. They do, however, “appear” to upload successfully. Here is what happens:

  • I can download, view, and delete attachments to calendar events which were added from the iCloud Calendar website just fine. (I noticed filenames I upload to the calendar appear in eM Client with a “+” where every space is).

  • Uploading an attachment through eM Client does not show an error, but it still does not actually end up on the cloud calendar. It does show up locally in eM Client though.

  • Uploading an attachment through eM Client seems to erase all other attachments on that event which were added from the web interface. After refreshing the web based calendar, all attachments are gone after an attempted upload. I tried with .txt and .pdf files, and also a .zip file.

I have a log file that I can e-mail to you.

Thanks for the help. I hope we can get this fixed!

Hello, are you by any chance working with a recurring event as well? I’ve managed to reproduce the issue with a recurring event, but it really seems there’s an issue when adding an attachment when there already is one uploaded from the site.

If you’ve enabled logging and have additional data, can you please submit these to me with a reference link to this forum topic or include the subject of this topic in the subject of your message, submit the data to mcgregor@emclient.com by using the send logs button in the advanced settings or by including the logs manually from the logs folder.

Thank you and sorry for the inconvenience,

These are definitely not recurring events… Just one-timers. I did e-mail you the log I had where I tried to upload a few attachments.

Hello, thank you for the submitted data, I’ve submitted an issue report to the developers for more information about this issue and we’ll check back with you as soon as we got some more information about this behaviour.

Thank you and sorry for the inconvenience,

Hello, 

Any news on this problem?

Hello, sorry for the belated reply, unfortunately it seems iCloud servers have changed the way the server handles attachments, so this feature will require some reworking and implementing new attachment handler for this server type. This may however require some more time, and the fix will be included in a future update of the application.

I’m sorry for any inconvenience, we’re working on resolving this as soon as possible.

Thank you for reporting this,