i need to manually setup exchange account em client 6.0

The workaround is not effective for me either. I think the case is simply that my company is running an Exchange version just prior to when “autodiscover” was introduced, and there is currently no way to provide enough settings manually in eM Client to get a connection.

It sounds like a solution is in development, and I’m glad to hear that.

don’t worry it is :slight_smile:


Configured my email address which did auto-discover my server, but mail won’t synchronise because of the error shown above. Having discovered the server, the name is visible in the server box in the tab mentioned, and could be edited. I know this doesn’t help others for whom auto-discovery doesn’t work. However I’m interested in the answer to my own question as well. Thanks.

I will need your Exchange Web Service logs, go to Tools - Settings - Advanced and check Exchange Web Service under your account, apply and restart eM Client then try to synchronize with server (send and receive) and if you will see error message then from same advanced window click on send logs.

Send them to [email protected] together with this topic’s url.

Then you cam turn logging off.

I also had to use some ‘trickery’ to setup my exchange account in em client. I really hope we get a proper manual setup added to em client eventually! My workplace does have exchange 2010/autodiscovery but I don’t think they have the autodiscovery stuff configured correctly.:

In the initial setup I had to:

for the username I needed to put [internal-exchange-domain]\username. Without putting the domain in front of the username it just wouldn’t accept my password at all. Doing this let me continue setup. but after finishing I got a connection error.

Then I went into the settings and changed the “server” field of the exchange account to the correct external EWS URL for my workplace’s exchange server. After doing that it gave me an error about username and password. So then I *removed* the domain and backslash from in front of the username and hit OK on the prompt. Then it connected and worked fine.

I’ve got it working by changing the Outlook settings to my mail server - the only problem with this method is that I can’t find a way to open a shared calendar from my exchange server.

Here’s how I got mine working.

  1. Added an entry for autodiscover to my hosts file. ie: autodiscover.mydomain.com

  2. Set up exchange account using DOMAIN\username as credentials

  3. After account was created, changed server to proper URL ie:

  4. Change credentials to use just username (without DOMAIN)

Hope this helps others.

Hi, I have the same issue, its just impossible to connect my exchange account, wich was why I wanted this cient in the first place. Please fix this :slight_smile:

Hi, in next update which is scheduled to be released soon there is this change:

“- Allow manually entering a server name for Exchange accounts after a failed autodiscover”

Also we made some compatibility improvements so please be a little patient until next patch will be released.


Does not work in the latest free version. You cannot get your account saved at all so I’m not able to change the server field in the correct external EWS url. So, too bad, it looks promising, but doesn’t work when autoconnect is not an option.

The patch mentioned, is this v6?
Are “Allow manually entering a server name for Exchange accounts after a failed autodiscover” included in v6?

Hi, yes this option is included in version 6 since release 20012.

Thank you,

Be aware that the Exchange server version must be new enough to support the Exchange Web Services (EWS) protocol, or else even the newer eM Client versions will still not connect.  Exchange 2003 and the earliest Exchange 2007 don’t use EWS and are not compatible.

Yes only Exchange version 2007 with SP1 and later are supported.
Thank you for pointing that out.


I use a hosted exchange account which requires use of a proxy server.  Is there any plans to introduce the ability to set a proxy server?


Hi, eM Client unfortunately does not support proxy setup, and the feature is not currently on the roadmap to upcoming releases, however we have a workaround for users using Windows credentials for authentication over their proxy, which should enable the ability to use the proxy with eM Client.

In case you’re using such setup, send me an email to [email protected] and I can send you the configuration file for your proxy.
However note this is only for use with windows credentials.

Hope this helps,