I have tried to write rules. They don't work!

When I started, there was a “spam” rule, already created. I is not doing anything. I have written one rule. I have tried it several ways and none of them do anything. I can write rules in Outlook that work, but eM Client rules are not working. It seems a trivial rule:

After message has been received
with ‘Name:’ found in header

move to New Spam

I displayed the header of the email from Best Buy and copied and pasted the text, then appended “Name:” [which you insisted that I add]. Yes, the “New Spam” folder exists. Yes, the rule is enabled. Yes, the power cord is connected and the computer is turned on. :wink:

When I click on “Apply rule…” and select the inbox [where the subject email from Best Buy is located], then click on “Run”, nothing happens.

I’m going insane…

The existing Spam Rule  simply looks for spam headers added to the message by your email server. This is what the Rule looks like:

If the message is identified by your server as spam, then eM Client will move it to the Junk E-mail folder. If your server does not update the header, then eM Client can’t do anything.

I don’t know that “Name” is a valid header.  “From” is the header that contains the email address of the sender.

So after entering the text as above, your Rule will look like this:

Easy peasy. :slight_smile:

When I tried to enter your “From” string, it was entered as:

Name:<BestBuyInfo@emailinfo.bestbuy.com>

Your version has single quotes instead of the “<>”.

When I tried to use single quotes around that string, I got a message from eM Client saying that "Header words must be specified as “Name: Value” pair.

Easy peasy back atcha…:wink:

Yes, Name: Value.

Name = From
Value = BestBuyInfo@emailinfo.bestbuy.com

Therefore   From: BestBuyInfo@emailinfo.bestbuy.com

No quotes!!!

==================================================================

Step by step:

Go to Menu > Tools > Rules , click on New Rule and select Apply custom rule on messages I receive and Next

Scroll down and select with words found in the header.

Click on words and enter the following (no quotes, so exactly as in the next image) From: BestBuyInfo@emailinfo.bestby.com

eM Client will insert the single quotes for display purposes, but they are not part of the argument.

So . . . your screen should look EXACTLY like the image above. Again, no quotes!!! I thought my image in the previous comment was clear. :wink:

Click on OK, then Next, then select the folder.

QED

I apologize for being so literal minded. I appreciate you taking the time to write those detailed instructions. They were perfect. At first I thought you failed to say click on “Add” before hitting “Ok”, but I tried it your way and it worked.

I wonder why the last box is labeled “Searched words”?

I very much appreciate your help and quick responses. I also got a reply from Anthony Cooper, who suggested using “From people” instead of “With words found in header”. He assigned Ticket ID: 74022.

You can also do it using the wizard by right-click on the sender’s address and choosing Create Rule from.  That will create a Rule that uses “From people” the same as if you do it manually the way Anthony suggests. However, blacklisting is probably a better way to achieve this. Right-click on the message and choose Move to Junk > Move to Junk and blacklist email/domain. The blacklist uses a single list for all the custom addresses you have added, rather than having multiple or complex Rules.

Using the header value in a Rule is more flexible as you can use a partial address which you can’t do in the other ways. So you could create a Rule to move addresses that contain just part of the address such as  From: mailinfo.bestbuy.

1 Like

I appreciate having that flexibility. I wrote 2 more rules and one of them just worked; moved the email to my Spam folder.

In some other email clients, “From people” requires the “person” to be in the Contacts list. Apparently eM Client does not have this limitation? I may try the “Create Rule from” approach.

If I use the blacklist approach, is the list view-able and editable?

No, eM Client does not require the person to be in the contacts as the Rule is fully self-contained. Would be a mission if you deleted a contact and then the Rule stopped working. Like if you delete or rename a destination folder, the Rule is not automatically updated - it just stops working. ;-(

The Blacklist Rule will appear with your other Rules once you have added an address or domain as I described by right-click > Move to Junk. The list is fully editable, so you can change, delete or add addresses and domains manually.

From my observations there is no way to create a rule that uses a partial email. If you create the rule from message there seems to be an option to use begins with, ends with, contains , etc. but you can’t change the compare part of the address. If you make a rule without using a current message you are restricted to addresses I assume that are contained in the entirety of all emails in the database but I cannot add a new partial email

The option is Contains.

That means the email address will contain whatever text you use.

All those options are there but there’s no way to apply them to the address that was picked up off the email nor is there a way to change the email addresss to use one of the other options.

No, you have to create the Rule yourself.

Go to Menu > Rules, and create a new Local Rule.

I tried that. Then I only can add existing emails and there’s no choice of any of the starts with, ends with, etc.

You see what happens when I try to do they 1st step. It brings up a list and blocks the buttons. theres no contains or starts with even avaiable.