I delete a contact but it's still there in auto fill.

If I delete a contact from the contacts list it diasappears from that list. However, when I address mail the deleted address appears in the auto fill list and I can’t get rid of it?

you can clear recipients history here: Tools - Settings - Send - Recipients History

This was the solution. Thank you for a good job.

The current eM Client 5.0.17263.0 seems to need a different answer to that given above by George.

My Contacts list contained many contacts that I’d never heard of (I think eM Client must have picked them off some multiple-addressed, multiple-forwarded, ‘virus warning’ emails that I received last year from a couple of silly but well-intentioned people that I hardly knew).

I deleted the unwanted contacts but they still come up when I click on ‘To’ in new emails - and I can’t find any way to get rid of them!

Actually, when you click on To button in “New email” window all what appears is your Contact list so I assume that you have to have those addresses saved in one of your contact folders. Can you take a look on it?

I’m sorry, George, I didn’t describe the problem very well. I’ll try harder this time!..

If I click on the word ‘To’, my Contacts list comes up and it contains only the contacts I have chosen to keep. That works perfectly.

But if I go my normal route and enter the first letter of a contact name in the ‘To’ address box, a list appears of the contacts starting with that initial that I’ve chosen to keep, but also many with the same initial that I had deleted.

I can find only one Contacts folder, and this shows as ‘Local folders/Contacts/’. It seems as though there’s a hidden Contacts folder that contains all current and deleted contacts.

Thank you for clarification - what you are describing is suggestion list which suggests contacts from your address lists and from Recipients history. You can clear recipients history here: Tools - Settings - Mail - Compose
Hope it helps.

Many thanks, George. Easy when you know how!

I’ve also unclicked “Store composed mail recipients for suggestion” (the meaning of which I couldn’t previously understand) in the hope that the problem doesn’t re-occur.