I am not able to send an e-mail. Problem with SMTP.

I don’t know what happened, but I am unable to send mail via eM Client. Everything worked fine, but the next day it didn’t work anymore. I’ve done just about everything. I’m out of whines. That’s why I’m writing here.
What I did?

  1. I changed the port, I tried 465, 587, 25
  2. Use SSL/TLS if available
  3. I turned off the firewall and antivirus
  4. I uninstalled eMClient and reinstalled it
  5. I disabled all programs in Start and launched eM Client.
  6. I also installed an older version of eMClient version 8 (currently updated to version 9).
    Nothing works. I am unable to send mail from any account, not only from Google.
    I can receive mail from all my accounts but cannot send from any of them.
    Any ideas?

What errors are you seeing in MENU > OPERATIONS > LOG?

Have you tried each of the other 2 “Security Policy” options?

Have you tried rebooting your PC?

Have you tried rebooting your router?

If you use a VPN, have you tried turning it off?

Have you visited your Email Host to determine if they are having SMTP “issues”?

20:25:50 XXXXX gmail. com SMTP Connecting: To XXXXX gmail. com
20:26:00 XXXXX gmail. com [SMTP] MailClient.Accounts.ConnectionException: Invalid server reply when connecting: ‘Unexpected end of stream.’.
at MailClient.Protocols.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
at MailClient.Protocols.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
at MailClient.Commands.Command.Process(WorkerStatus status)
— End of stack trace from previous location —
at MailClient.Reminders.ReminderManager.TimerSendLaterTrigger(Object sender, ElapsedEventArgs e)
EnqueuedStackTrace =
at MailClient.Protocols.Smtp.SmtpAccount.<>c__DisplayClass5_0.b__0()
at MailClient.Protocols.Common.AccountBase.RunIfOnline(Action actionIfOnline, Action actionIfOffline)
at MailClient.Protocols.Smtp.SmtpAccount.SendAsync(IEnumerable1 items, Action1 sentItem, Action1 completed, CancellationToken cancellationToken) at MailClient.Accounts.BindingAccountBase.<>c__DisplayClass84_0.<SendAsync>b__1(ISendAccount1 sendAccount)
at System.Linq.Enumerable.SelectListIterator2.MoveNext() at System.Threading.Tasks.Task.WhenAll(IEnumerable1 tasks)
at MailClient.Accounts.BindingAccountBase.SendAsync(CancellationToken cancellationToken)
at MailClient.Accounts.AccountManager.SendInternalAsync(IAccount account, CancellationToken cancellationToken)
at MailClient.Accounts.AccountManager.SendAsync(IAccount account, CancellationToken cancellationToken)
at MailClient.Reminders.ReminderManager.<>c.b__80_1(IAccount a)
at System.Linq.Enumerable.SelectEnumerableIterator2.MoveNext() at System.Threading.Tasks.Task.WhenAll(IEnumerable1 tasks)
at MailClient.Reminders.ReminderManager.TimerSendLaterTrigger(Object sender, ElapsedEventArgs e)
at System.Runtime.CompilerServices.AsyncMethodBuilderCore.Start[TStateMachine](TStateMachine& stateMachine)
at MailClient.Reminders.ReminderManager.TimerSendLaterTrigger(Object sender, ElapsedEventArgs e)
at System.Timers.Timer.MyTimerCallback(Object state)
at System.Threading.TimerQueueTimer.<>c.<.cctor>b__27_0(Object state)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.TimerQueueTimer.CallCallback(Boolean isThreadPool)
at System.Threading.TimerQueueTimer.Fire(Boolean isThreadPool)
at System.Threading.TimerQueue.FireNextTimers()
at System.Threading.TimerQueue.AppDomainTimerCallback(Int32 id)
at System.Threading.UnmanagedThreadPoolWorkItem.ExecuteUnmanagedThreadPoolWorkItem(IntPtr callback, IntPtr state)
at System.Threading.UnmanagedThreadPoolWorkItem.System.Threading.IThreadPoolWorkItem.Execute()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading.PortableThreadPool.WorkerThread.WorkerThreadStart()
at System.Threading.Thread.StartCallback()
GUIStatus_Exception_Reported = True

Have you tried each of the other two “Security Policy” options?

Have you tried restarting your computer?

Have you tried restarting the router?

If you use a VPN, have you tried turning it off?

Have you visited your email provider to determine if they are experiencing SMTP “issues”?

Sounds like it might be a Mail Host issue that requires a direct contact with Host Support…perhaps they have a STATUS WEB Page that contains what the problem might be.

As of this morning I am having the same issue. My Gmail account is working, but the Comcast account is not. If I go online to my Comcast email, I can see all the new messages, and they do appear on my cell phone as well. The only place that is not working is my emClient email for Comcast. Cannot send or receive. As of 8 hours ago, everything was fine. I went to bed, and woke up to email not getting to emClient.

Same problem with Comcast emails not sending as of this morning using eM client. However same problem occurs in Outlook client with my husband’s comcast email account. Talk at length to Comcast with no answers from them. Turned off all Norton and firewall stuff. No VPN on.

Now we are both unable to receive (as well as send) comcast emails in EM or Outlook. Any info on this problem from others? Also, if I delete my email account in eMclient (in order to setup anew), what happens? Do I lose all my inbox or saved emails?

Update. After spending the whole day trying to fix this problem, I found a link that explained that on Comcast’s webmail, there is a setting that allows or denies access to emails from a 3rd party app. When I went to that setting, it seemed that access was not enabled. (why this would be when I’ve rec’d my emails on a 3rd party app for years, perhaps something inadvertently turned it off?) In any case, when you go to click the box to enable access, there is not a “save” or “finish” button, so you don’t know if you enabled it or not. When you back out of that screen and go back in, it shows at first as not enabled (not checked) and then quickly changes to a check. I enabled this several times to be sure.

Suddenly I was able to re-access all my emails, sending and receiving ok from both my and my husband’s email programs. So if anyone is still experiencing this problem, you might try that fix.

A word of caution, however, I also found a long support string about the same problem. Many folks experienced it, and the crux of the issue seemed to be that email send would stop working (on Comcast emails in 3rd party app) sometime in mid-morning. Later in the day or evening it would turn back on. Our emails also went down in the am, and then around 5 or so, were back up.

So the long and short of it is, I don’t know if checking the box enabling 3rd party apps on Comcast webmail fixed it, or it’s some weird Comcast overload situation. Either way, it appears all is well for the moment.