how to switch off displaying any picture files in letters attachment.

If the images are attached, the only option is to display messages as plain text. Go to Menu > Tools > Settings > Mail > Read.

I don’t know that this is actually a solution, because you lose the formatting in the message. Maybe some text was in color, or bold etc.

If the images are linked, the first option below, which is the default, will only display images in messages from senders that you specify. Otherwise it will not download them at all.