How to STOP program adding email addresses to "Contacts" section !?

Hello there.

In my eM Client 5.0 program, I have noticed that, for every new e-mail sent (or perhaps received), eM Client automatically adds his/her e-mail address to the “Contacts” section, with no option to agree or disagree.

I do not like at all this automatic option. After going through all the settings, unfortunately I see that there is no way to change this.

Please, could anyone tell me how to stop this? I would appreciate any help given.

Many thanks.
Best regards from Spain
Marcos Molina

Hello,

so after you write email to someone it is added as new contact? Can you please make sure by checking in leftside bar under “contacts”?

or if this is cause that those emails are shown when writing new email (with red cross on right side) then it is just whispering function and you can delete that email by clicking on red cross on right side of that line.

Jan

Hello Jan, thanks for your answer.
I have confirmed that eM Client 5.0 automatically adds to my Contacts List a new contact for every new email message I send (only if the email address is a new one).
What must I check in the Contacts section of the left bar? There are no settings there.

so after every email you send you have new contact under “contacts” in leftside bar???

If so then this is very weird behaviour… can you try this version http://www.emclient.com/dist/v5.0.190… if it will help you? Just install it over your current one.

Jan

Hello Jan.
Thanks for your update.
I have downloaded and installed the version you linked me.
Nothing has changed. It still does the same: email sent, contact added automatically!!!
This is so annoying as it fills me up my contact book with lots of undesired contacts.

this is weird, can you show me screenshot before sending email of that email with some contact you have not in contacts and after that screenshot with new contact in contacts? And can you tell me what email provider do you use?

Jan

Hello again Jan,

Thanks for getting in touch again.

I know this is very weird, I’m surprised that no one else has claimed about this problem before.

In response to your enquiry:

  • My email provider is Gmail.

  • Screenshots: I am attaching 3 screenshots that belong to a real example of email address added to “Contacts” automatically, without asking, after me sending an email message:

001.jpg — 14 NOV 2013 - Inbox (Received) - email message received from Vallorcine Tourist Office as an answer to my previous question posted through their web contact form on the 12/NOV/2013.

002.jpg — 14 NOV 2013 - Outbox (Sent) - email message sent by me to thank the Tourist Office for their answer.

003.jpg — 14 NOV 2013 - “Contacts” page - You can see how “OT Vallorcine” (Office de Tourisme Vallorcine) has been added. That contact obviously was not there before and of course I didn’t put it there either!

This happens every time I answer anybody who’s not in my “Contacts” book.

I started another thread about this same issue: Link

I think what is happening is when you send somebody an email, it’s not eM who adds who you’re sending the email to to your contacts list. It’s actually GMail adding it.

If you go to the GMail web site, in the right-hand column on the bottom, there’s like a list of contacts down there. When you send someone an email, GMail adds them to this list.

But if you go to contacts.google.com, that list of auto-added contacts doesn’t show up.

I think eM is just pulling more information out of Google Contacts than it needs to. Hopefully there’s some Google API that makes it easy for eM to filter out all these auto-added contacts.

This reply was created from a merged topic originally titled
Auto-added GMail contacts are showing up in eM.

Whenever I email someone, the Gmail web site has a little list off to the left towards the bottom that the person I emailed is added to. Like if I email support@acme.com about some widget I bought from them, Gmail puts support@acme.com in that list. However, if you go to contacts.google.com, that email address isn’t in your contacts.

What’s bothering me is that the people in that list Gmail keeps is showing up in my contacts in eM. I’m not sure of a use case where anyone you ever email, you want all those emails in your contacts.

It works okay for me personally because I don’t have a lot of contacts and I just go through and delete them manually. But as far as recommended eM to my clients, I really don’t see it. A lot of people have a couple of hundred contacts and auto-adding everyone they email will just make their contact list a mess.

Is there any existing solution for this issue? Is the eM client being updated to address this issue?

because these issues are same I have merged topics together, please always use previous threads is possible.

I will need your GData logs, go to tools - settings - advanced, check GData under your account, apply and restart eM Client.

Simulate steps that leads to your issue and after that send logs… to galis@emclient.com together with this topic’s URL in subject.

then you can turn logging off.

Jan

John, did you try re-creating the issue yourself? If you can’t recreate it yourself, I’ll be happy to provide that information. But even if I provide that information, you’re still gonna have to do that stuff to recreate the situation there.

Have you tried recreating the scenario and not gotten it? If you have tried and didn’t get it, I will be happy to do that stuff in an effort to contribute.

Yes, of course I did, Anyway I have realized that this is Gmail’s feature, they add new contacts after every sent email - in 6th version there is workaround for this that we show folder my contacts as default where are stored only your contacts you wan to have.

Jan

I am also having this issue and there does not seem to be a solution posted here. You talked about a workaround by viewing the folder in my contacts, but that only shows “contacts” for all these contact entries. I am using version 7.2.37929.0. Can someone please tell me how to stop these from being added to my main contact list or to put them under another category.

eM Client does not automatically add recipients to Contacts. What it does, is add recipients who are not in your Contacts to the Recipient History.

You can disable that in Menu > Tools > Settings > Mail > Compose > Recipients History.


These will never be displayed in the Contacts section of eM Client, but will be available to auto-complete in the To field when creating new messages.

However, some email providers will automatically create contacts from recipients, and they will be added to your Contacts if you are syncing your contacts with the provider. To change that you will need to look at the configuration using the web interface for your provider.