How to manually add exchange/ews server (.asmx) for mail account

Hi, I am using eM Client 6.0.23421.0 (free) on Win7. If I try to add an mailaccount via exchange, the GUI only allows me to enter my mailaddress, user and password. It pretends to find the server itself but claims that authorization failed. I am pretty sure that the wrong EWS server is used as the combination of user/password works both with davmail (which I planned not to use in favor of eM Client) and evolution (under linux). Adding manually via “other” only provides options for IMAP and POP but not for EWS. How can I add an account specifying manually the EWS/OAB server address? Thanks in advance, Olli

[update] it’s said at https://forum.emclient.com/emclient/topics/i_need_to_manually_setup_exchange_account_em_client_6_0 that setting the server manually “is included in version 6 since release 20012.” (in case autodiscovery failed). Can anyone tell me how to do that? Thank you!

Hello,
if your server is correctly set up, the option to input your server manually should appear automatically after failed authorization.
Please test your server connectivity on this page: https://testconnectivity.microsoft.com/
If it doesn’t pass then I’m afraid you won’t be able to use it through eM Client either.

Best regards,
Olivia

Dear Olivia,

thank you. I just performed the EWS connectivity test at the MS web page with autodiscovery using the identical “domain\user”+mailaddress+password that I typed in eM Client. It worked, no error messages. In eM Client though, I do still get the message that authorization failed. Since a server is found, however, I do not get the option to input one manually.
Can I check which server address eM client tries to use?
If it is not the server address, what else could cause the authorization problem given that the user and password are correct?

Best regards, Olli

[update] I can type any random letter combination in the email field and still eM Client claims to have found the server but that authentification failed and I should check password and mailadress.

[update2] The identical “domain\user”+mailaddress+password combination works in Evolution under Linux, where I can manually specify the EWS/OAB server address. So I guess thats exactly what I would need to do in eM Client as well.

Hi Olli,
can you send the result of the test connectivity test to rust@emclient.com with a link to this forum topic in the body of the message?

Best regards,
Olivia

Hi Olivia,
thanks again. That test is all in german and I am not sure if can share all the data involved. Anyway, I had a closer look at the details of the test. Obviously, I misunderstood the output “all tests performed successfully”, which only seems to refer to the second server address - which was tested automatically by the connectivity analyzer after the first one failed :confused: I am sorry, could have seen that before. So the result is:
(1) test https://maildomain:443/Autodiscover/Autodiscover.xml -> error with SSL certificate name
(2) test https://autodiscover.maildomain:443/Autodiscover/Autodiscover.xml -> no errors at all
I guess eM Client does version (1), doesn’t it?
Can I somehow use version (2)?

Best regards,
Olli

Hello Olli,
that’s why I gave you my work email address, so I could look at the outcome privately.
In any way, you need to fix your SSL certificate, I’m afraid that if the server is not setup correctly eM Client will not be able to detect and connect to it.

Best regards,
Olivia

Hi Olivia,
allright. Sadly, I will not be able to change any certificates. Since it works in other software, I see two additional options: Is there a way for me as user to
(1) tell eM Client directly the EWS server address (without autodiscovery)
or
(2) to change the autodiscover look-up address to version (2) from above?

Would be a pitty if not as I would really love not to be forced to use MS Outlook :wink:

Hi Olli,
I’m very sorry but if the server isn’t set up correctly, eM Client can’t connect to it. Try contacting your server provider about changing the SSL setting.

Best regards,
Olivia

Hi Olivia,
as I already said, it would be working if I could just set the server addresss manually (as it does work in other apps). Anyway, I take your answer as a “No, you cannot set the server manually if eM Client does not ask you to do so.” Would be great if you would implement that option in future. I would be glad to give eM client a second try then…
Regards,
Olli