How to make rules work for domains

I’m recieving mails from the same domain, but from different senders, exampel:

[email protected]
[email protected]
[email protected]

is there a possible way to add only the @bbb.ccc to a rule without having to add the parts before @?

Thank you!

Yes, this is possible - simply add domain part of the email address into rules conditions.

Thanks for the fast reply! I was trying first without the @!

Let me clarify: to make the rules work for a domain I should enter “” as a condition. Am I correct?

Hi Marian, yes, to create a rule sorting emails from a specified domain, use ‘’ as the sender’s email, the rule will work with the whole domain using this setup.

Hope this helps,

Thank you for the prompt reply.

I’ve done it this way, but unfortunately it works just for the outgoing mail, the incoming does not trigger the rule.

Best regards,

Marian Yordanov

Hi Marian, I’m positive this setting should be working. Can you please make a screenshot of your Rule setup, and post the exact version number from Help > About?
Also note that Rules only apply to newly received unread email, so if the message was read on some other device prior to the eM Client’s synchronization the Rule will not sort the message appropriately.

Thank you,


Here are the screen-shots. Thank you for your support. I am sing GOOGLE Applications account (IMAP).

Probably the reason the “Incoming” rules do not work is because the messages do not land in the “Inbox”, but to a subfolder (I am using the native GMAIL rules for this).

Hi again Marian, do you have the Rule active in Tools > Rules, is the checkbox on the left side next to the rule, checked?
What if you try to applu the rule manually? Right click your mailbox folder and select Apply Rule manually?

Thank you,

Yes, the rule is “Active”. The rule works fine when applied manually. Did you read this? It could be the reason.

“Probably the reason the “Incoming” rules do not work is because the messages do not land in the “Inbox”, but to a subfolder (I am using the native GMAIL rules for this).”

Hi again Marian, yes that is the reason, eM Client only applies rules for unprocessed email that is newly received in Inbox.
So if you want to keep using the server based rules, this rule won’t be applied.

Thank you for understanding,

I will apply the rule manually. Thank you for your time on this matter.

“eM Client” is a great tool!

No problem, glad I could help, unfortunately there’s no option to apply rules automatically in other folders, maybe in future releases.

Thank you,

I too have had this problem, with addresses such as @amazon, or @facebook.
Have you come up with other solutions?

Hope this works…I’m a newbie…sorry if I did something wrong :slight_smile:

Hi Steve, non of your submitted screenshots were available for viewing on dropbox, so I’ve removed the links from the topic to keep the conversation clean. Please upload the screenshot here using the upload button, or send us working links to the image.

If you want to setup a rule for a certain domain, all you should need to do is to add the domain as the address filtered by the rule in ‘’ format.


OMG, thanks Paul. I was starting to lose my mind over this. I put and it worked, now I can go to bed at 4:46am. I’ve been messing with this for hours. So many thanks.