How to delete suggested address in drop-down?

Perhaps anyone can help me with this. When I type a name into any field suggestions come up. One is a spelling error that, naturally, bounces back if I accidentally use it. I want to eliminate it from the drop-down. I thought I knew how, but my common sense attempt turned up nothing. Thanks in advance.

Hi, if the suggestion comes up you should be seeing a red cross next to it, if you click on it it should be never displayed again.
Although I’m not sure what exact field are you talking about, this solution should work for example with To: adress field.

Thank you,
Paul.

I feel like a fool for not seeing that BIG red “X”. Thank you!

No worries, glad it works, thank you,

Paul.

Hi, I’m having the same problem with unwanted addresses in my drop down suggested email box.  Mine does not have a red X or an X of any color.  This particular email address is an old one that has been replaced by the new.  Every once in a while it grabs the old addr.  I’ve deleted it from my Contacts, but it remains in the drop down box.  Any suggestions?

Thanks,
Mike

tools > settings > mail > compose

click on [show recipients…]

there you can delete specific e-mail addresses.

screen shot:

Wow - that’s slick!  Thank you Hans!  I really appreciate the help.  You are a “Champion”.  :o)

thanks, Mike!

Glad I could help you.

I have this issue too. Couple of old email addresses that I know are not valid and cannot delete.  They do not have a red x next to them and I already cleared out all email addresses through tools/settings/mail/compose.  When I right click on the address and go to edit contact it shows that the contact is in a folder called “Local Folders”.  I have no clue where to find that folder and to clear out it’s content.  Any help???

Go to menu/tools/settings/general and check “Show local folders”.  They will then appear at the bottom of the folder pane.