How to cancel unwanted auto archiving?

Incoming mail occasionally goes straight to All Mail so I miss it!

I would like an answer to this too, as it happens to me on occasion. Upon Googling this, it appears it is something to do with gmail treating  incoming mail as promotions. This can be changed by configuring gmail inbox  to only  select as Primary,  but this hasn’t totally fixed the problem

Try going to your gmail web client, click on settings/configure inbox and make sure only “Primary” is checked.  Having other boxes checked will remove the inbox flag if they are determined by gmail to belong to that category and they will appear only in All Mail.

Yes it is already set to Primary.

As is mine, but it is still occurring intermittently.