How do I stop eM Client from trying to deliver email with too large attachment?

eM Client keeps trying to send an email with attachment too large. I keep getting errors.

Hi Doug,

Here’s one suggestion - at least that’s what I do  :
Take eM Client off-line , move the mal from Outbox to Drafts.
Open the mail and edit it : Remove the attachment and opload it to eg Google Drive  or OneDrive
or any other file hosting service and get the download link.
Put that link in this email - with- or without- explanation and send it…
(after you put eM Client back online  haha)

Usually I know the limitations beforehand - ISP- or mail provider- restrictions on either side…


Hello. I have this same error. But there is nothing in the outbox or drafts whether I am online or offline. So I can’t remove the mail or move it since I don’t even see it

Right-click on Smart Folders and select Outbox

You will find your outgoing message in that folder.

eM Client uses the Local Folders Outbox to store messages that are being uploaded. Those folders are not visible by default. You can enable them in Menu > Tools > Settings > General, but the Smart Folder is probably a better solution.

That did the trick. Thanks for the quick revert!