How do I disable colored tags? [SOLVED]

It seems that my GMail labels/tags have recently started appearing in all different colors. At first I thought this was only in the beta, but now I am seeing it in the regular version too. Is this a newly introduced feature or did I just miss it before? At any rate, I am looking for a way to completely disable colored tags, as it is far too distracting for my workflow. Many thanks!

Menu > Accounts > [select your account] > IMAP > Tags > tick the option “Show only locally defined tags”.

Does this solve the problem? I am not sure because I don’t use Gmail.

1 Like

Many thanks! On the beta there’s actually an option at the place you mentioned for random colored tags, which I have now disabled.

1 Like

Awesome thanks @eisbaer for the info :slightly_smiling_face:

I too have had those random coloured Gmail account label tags for years which was annoying and never knew how to disable them, as prefer just my own custom coloured tags.


@cyberzork Have you managed to do it with a Gmail account?


Have you managed to do it with a Gmail account?

I just deselected the Show Random Colours and set Important tags to Never under the Gmail IMAP tab in Accounts. So that then normally just leaves your local tags you setup in eM Client. Make sure you “Save & Close” in Accounts after deselecting those options.

Note: The Inbox grey tag you are going to see anyway as that tag comes “from Gmail online” automatically when new emails arrive in your Inbox.

(eM Client IMAP Tab Gmail account)

1 Like

Hi again!
Thanks for your reply!
I have already set Important tags to never, and would have loved to untick “Show Random Colours”, but this option doesn’t appear on my settings panel… although I run the latest eM version (9.2.1777).
Tick box not showing up

1 Like

You need to also have the Google Settings service ticked in the General tab. If the random colors option option doesn’t appear, click on Save & Close, then open Accounts again.

Hi Gary!
Thanks! Now I have the option. It is unticked, and I have no more random colors, but… Gmail colors that override my local labels colors.
Any clue on how to deactivate those Gmail colors or override them?

You can change the colors in Menu > Tags. Then select the Gmail account from the dropdown next to the Save & Close button. Select a Google tag and edit it. Editing them here will change them on the server as well.


Got it! Thanks for your help!