How can I set up Trash Folder to NOT DELETE AUTOMATICALLY?

I notice that my Trash keeps only the latest deleted emails.

How can I setup that I want to do that manually. So, no automatic empty of the trash.


Check that you don’t have any type of “Rules setup” to automatically delete emails via “Menu / Rules”.


Also check that you haven’t enabled “Empty trash on exit” via Menu / Settings / General.

If you have No Rules setup to auto delete emails and don’t have the option enabled to Empty the trash on exit, then if you have an eg: “IMAP or Exchange” account (Non POP) setup, you might have a “Server Mailbox setting” that’s is causing this.

So check for any setting in your mailbox online if you have one of these accounts, as by default normally EMC will just “mirror” IMAP / Exchange server account folders…