How can I see date and time 'yyyy-mm-dd hh:mm' in Received column (like in OutlookExpress) ?

I always use received time to check my jobs during the day. In Outlok Express it was easy to fill work log at the end of day - I’ve taken a short look at the messages list and I had fast info (in my mind) about all issues during the day. Now I can’t see time in the received column, so I have to open every message to check it. You can see an example at:

Hi Jerzy, you should be able to see the “received” date in the list of emails, however if you’re using the messages on the right layout, you’ll only be able to see the time of reception for several days, after few days, just a date is displayed in this view.
However you can switch to the messages on the bottom view where you should be able to see the full time format in the “received” column.

Or just move the handle for your email list to the right to adjust the size of the list, when it get’s large enough you should be seeing all the available columns for that view.

Hope this helps,

I can see “received” date but I can’t see the time.

I’m usually working on a few days with full screen layout. For current day I can see ‘HH:mm’, for previous days ‘d MMMM’, for previous years ‘yyyy-MM-dd’.

Why doesn’t the application show Received in one format 

yyyy-MM-dd HH:mm

or in

ShortDate + ShortTime

 format ? (or for current day ‘HH:mm’ and for previous days ‘yyyy-MM-dd HH:mm’).

This is much more useful information then multiplied month name.

Sorry for the misunderstanding, unfortunatelly it is not possible to display the time, even in the columns view. You should be seeing the time of reception for up to two previous days, however after the message is older, only date is shown (e.g. month DD). Not really sure what you’re referring to by the multiplied month date.

There’s no option to change this setting unless adjusting some of the database files, that’s however not a supported interference.

Thank you for understanding,

Not really sure what you’re referring to by the multiplied month date.
You can see it on the attached screen.
Instead of 7 x ‘21 października’
there is much better to see ‘2014-10-21 11:24’ ‘2014-10-21 13:34’ ‘2014-10-21 13:52’…

'There’s no option to change this setting unless adjusting some of the database files’.
What kind of database adjusting do you mind ?
In database mail_index.dat in the table MailItems you have already receivedDate field defined as TIMESTAMP. So you have to format datetime before you show it on the screen.
Please, define different format string or give this possibility to users in application’s setting - that’s all.

I really like your software, it looks good and works very well. I’ve decided to use it instead of Outlook Express and I need only to see time on the maik list to be a very happy user :wink:

Thank you for understanding,

I also think giving 1 or more date time formats adjustable by end users would be nice. Maybe 1 format for all e-mails, or multiple for recently received e-mails and 1 format for e-mails received more than x days ago.

Hi again, I’m unfortunately not completely sure what exactly do you have to alter, one of our users suggested the edit here on the forum, but I can not seem to find the topic. As I noted previously it is an unsupported interference into eM Client’s database and we do not recommend any database altering.

I understand the suggestion, I believe it might be helpful for a lot of users to include a different time formatting.
I’ll make sure to forward your suggestions to the developers and hopefully we can include this in future releases of eM Client.

Thank you,