How can I increase Server Timeout?

When sending mail with eM Client I receive errors about timeout connection.

With other client such as Outlook or Windows Live Mail, I can increase this time and solve the problem. It is possible to do the same with eM Client?

Hello,
unfortuantely you cannot manually change the timeout for eM Client. The time limit should be enough for most servers though, so perhaps your issue is not with the time limit, but with the connection being blocked by a third party application.
Could you please copy the content of Tools>Operations>Log window next time you experience the Timeout error?

Regards,
Olivia

Hi, I have the same problem with Outlook.com, See the my log here:

2:31:42 PM email@outlook.com [IMAP]  MailClient.Accounts.ConnectionException: No server response within 30 second timeout. —> System.IO.IOException: No server response within 30 second timeout.2:31:42 PM    at MailClient.Imap.Base.Connection.Connect(Func1 getStream) 2:31:42 PM    at MailClient.Imap.Base.Connection.Connect(String receiveHost, Int32 receivePort, Boolean explicitSsl) 2:31:42 PM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken) 2:31:42 PM    --- End of inner exception stack trace --- 2:31:42 PM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken) 2:31:42 PM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Connect(CancellationToken cancellationToken) 2:31:42 PM    at MailClient.Protocols.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore) 2:31:42 PM    at MailClient.Protocols.Imap.ConnectionContext..ctor(ImapAccount account) 2:31:42 PM    at MailClient.Protocols.Imap.Synchronizer.SynchronizeFoldersCommand.ExecuteInternal(WorkerStatus status) 2:31:42 PM    at MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status) 2:31:42 PM    at MailClient.Commands.Command.Process(WorkerStatus status) 2:33:51 PM [email@outlook.com](mailto:email@outlook.com) [IMAP]  Synchronizing subfolders: For folder [email@outlook.com](mailto:email@outlook.com)/ 2:34:22 PM [email@outlook.com](mailto:email@outlook.com) [IMAP]  MailClient.Accounts.ConnectionException: No server response within 30 second timeout. ---\> System.IO.IOException: No server response within 30 second timeout. 2:34:22 PM    at MailClient.Imap.Base.Connection.Connect(Func1 getStream)
2:34:22 PM    at MailClient.Imap.Base.Connection.Connect(String receiveHost, Int32 receivePort, Boolean explicitSsl)
2:34:22 PM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
2:34:22 PM    — End of inner exception stack trace —
2:34:22 PM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
2:34:22 PM    at MailClient.Protocols.Imap.ConnectionPoolEntry.Connect(CancellationToken cancellationToken)
2:34:22 PM    at MailClient.Protocols.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore)
2:34:22 PM    at MailClient.Protocols.Imap.ConnectionContext…ctor(ImapAccount account)
2:34:22 PM    at MailClient.Protocols.Imap.Synchronizer.SynchronizeFoldersCommand.ExecuteInternal(WorkerStatus status)
2:34:22 PM    at MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
2:34:22 PM    at MailClient.Commands.Command.Process(WorkerStatus status)

I really like emClient, despite some missing features that could make it even better, some of which has already been requested. However, this constant issue with timeout and inability to alter the connection timeouts for each account is frustrating. I hope this can be resolved or a workaround solution offered, because I am considering purchasing this product when the free trial is over. Although, I am not convinced that the product is completely OK, due to other issues I have encountered. I’l check these pages for reports of similar issues before logging them.

Thanks
Glenn

Here is an image of the error too:

I have double/triple checked my configuration and compared it with documented settings and they are fine. This leaves me thinking it is an emClient issue not the server. Although, perhaps it could be network. Yet, I am on a max 30Mbps cable connection for download speed.

Hello Glenn,
this could also be caused by third application blocking eM Client’s connection to yoour server. Please try adding eM Client to exceptions in your Antivirus software and Windows firewall and see if the connection issue persists.

Regards,
Olivia

Thanks for the response. Unfortunately, the antivirus software on my machine is locked by the corporate policy. I don’t have any issue like this with other mail clients. Why emClient?

Hello Glenn,
as a non-native Windows mail app from a smaller company the request for IMAP stream can be seen as dangerous by Windows FW and some security software.
Unfortunately we cannot influence this as the client needs to connect to the mail servers this way.

Regards,
Olivia

I am also having this problem. Most email clients allow adjustment of timeout values for slow connections. Saying “should be fine for most people” is not a valid answer or a reasonable development/design goal.  At least allow this to be configurable directly from raw configuration (file, registry, etc.) if not providing a GUI to do it.  EMclient works fine when I’m on a fast connection, but the minute I switch to a hotspot it throws timeout errors almost every time.  Outlook and Windows 10 Mail have no such problem – only EMclient.

1 Like

If you are otherwise having no problems receiving emails, you can turn off the notifications by going to menu/tools/settings/genral/general and un-check “Show window when error occurs” in the "Operations Window " section

Turning off notifications hides the problem but doesn’t fix the fact that email doesn’t come in on slow connections because you cannot modify the timeout.

1 Like

I totally get that, but if you can’t change the timeout, at least there is a workaround so the window does not keep popping up.