Hosted exchange calendar sync error

I have been evaluating eM Client as it looks a superb replacement to Outlook.  I use a Hosted Exchange account which syncs faultlessly with my mobile devices and of course Outlook.

I put the details into eM Client and within moments it found my account, and set it up.  My Inbox synced and showed the complete folder list that I have there.  However, when it tries to sync my calendar, it fails after a few moments of trying, suggesting the settings are not correct.

I like eM Client and if I can get it to work for me I will happily buy a licence…

The hosted exchange organisation is tidyhosts.com; they specify on setting up Outlook to use a Proxy.  eM Client of course doesn’t support proxy, but finds Exchange Web Service settings when it autodiscovers… any suggestions as to why eM Client is clearly connecting and starting to sync, but falling over when it gets to the Calendar??

Hi Dale, what version of eM client are you currently using on your computer, can you please check for the exact version number in Help > About? Are you seeing any errors while trying to synchronize the calendar?

Can you make a screenshot of such error and post it here on the forum?

Thank you,
Paul

Good morning Paul - thanks for the response.  I am running 6.0.21040.0
I have also as of this morning started getting another error on sync.  Please see attached screenshot, as requested.

Hi again Dale, can you please try to update your eM Client to this release and check if the issue persists, http://www.emclient.com/dist/v6.0.21364/setup.msi ?

If it does, can you please try to disable Offline Address Book synchronization in Tools > Accounts > Your Exchange account > Offline Address Book, and again check if the error persists in showing?

Thank you,
Paul

OK.  I did that.

Step backwards I’m afraid.  Firstly, on starting up now, it puts up a “please enter password” box as per the picture.  The password is already there, but to be sure, I re-enter it and hit OK.  The box doesn’t go away and keeps redisplaying until I click “Cancel”.  In the background, however, I have downloaded my Inbox and complete folder list, so it has accepted the password.  I think that may be a bug - SORRY - “Undocumented Program Feature”.

Secondly, it still crashes with the same error halfway through syncing Calendar.  I tried to doing as instructed and disabling OAB sync … it wouldn’t let me, proclaiming that the default account required it… see attached pictures for detail.

I can confirm I am now running v6.0.21364.0

 

Hi again Dale, sorry for your ongoing issue, I’m very sorry to see this, can you please try to navigate to your local folder > App Data > Roaming > eM Client and remove all the *.oab files from your eM Client database folder?

Reopen the application and check if the syn error persists.

If it does, please navigate to Tools > Settings > Advanced and enable Exchange Web Services logging for the problematic account,

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    When it occurs, please navigate back to the advanced settings window and submit the logs to my email mcgregor@emclient.com with a reference link to this forum topic by using the “Send logs” button.

Thank you,
Paul.

Thanks Paul,
I did as instructed, first removing all .oab files, then starting the application.  I got the same error, with the username / password not going away unless cancelled and was still unable to disable Offline Address Book, with the error “The Contacts Service is required by default email account”

I then removed the server string that showed in the OAB tab and tried again.  same error.  Sync failed again about halfway through syncing calendar.

I enabled logs, and exited the application, restarted and on encountering the error sent the logs to the email address specified using send logs function - or at least I have tried to - I am unable to see the email in my "Sent"box as the client is continually trying to sync the Calendar each time it fails.  The email I sent from eM Client is not showing up in any of my other devices "Sent items"which I would expect it to if it sent correctly…  I may try to recreate the email on OWA and send that way

Its got itself hopelessly tied in a loop.  It is failing to send the logs but keeps trying, the log is 113 MB so it is going to keep failing.  Even if I shut the application down and re-start, it immediately tries to send the logs.  I am going to delete the account, re-create the account and start again, except instead of using "Send Logs"I will use my OWA to send the logs and Forum Topic link to you

Hi again Dale, you should be able to remove the large message by running the application in offline mode, you can do so by holding the CTRL button when you click on the application’s icon and hold the button until the application finishes loading.

The Log files can also be found in your Logs folder under your local folder > App Data > Roaming > eM Client.

Hope this helps,
Paul

Hi there.  Only log in that directory is 2015-01-03_14-30-43 dale@ashleydale.com Exchange Web Services.log which is the one I emailled to you - did you receive it OK?

Hi Paul - any further update for me you can offer on this issue?

Hi Dale, can you please try to install this update, and re-setup your Exchange account using the automatic setup? http://www.emclient.com/dist/v6.0.21372/setup.msi

Unfortunately the issue with turning off your OAB synchronization, is currently an application issue, and should be removed in an upcoming update of eM Client.

However I’m afraid that if the authentication issue persists, this might be server issue, as based on the received logs, your items are being synchronized over Exchange.

Thank you,
Paul

Hi there,
Updated as advised - no difference I am afraid.  I managed to cure the authentication issue by removing the server string on the OAB tab.  I still couldn’t turn off OAB sync, but it at least stopped the constant request for authentication.

However, same error as previously noted - it failed when syncing calendar

Hi again Dale, can you please try to re-setup the account, and at the last window where you setup which services are available, uncheck the “Contacts” (e.g. only the option Mail, Contacts, Calendars will remain checked) option and finish the setup.

Regards,
Paul

I have just done as requested.  No authentication error - but still falls in a screaming heap trying to sync calendar

Hi Dale, what error are you seeing when trying to synchronize the calendar, can you make a screenshot of this error?

Thank you,
Paul

Good morning Paul,
Well I updated to 6.0.21527.0, recreated my account again and again did not select the second check box (Contacts)

And it still fails when syncing Calendar - but ONLY when syncing Calendar.  If I select each folder in my folder list it syncs those perfectly, pulling in all the emails. Again, it also syncs contacts happily if I select the contacts folder.

But if left to its own devices to sync automatically, as it would normally, it syncs Inbox, then goes to Calendar and after between 30 seconds and 5 minutes it fails with the following error:

And not at all sure if this will assist, but a screenshot of the Log tab of the above box showing Calendar starting to Sync and then the failure:

Hi again Dale, sorry to see this, can you please navigate to Tools > Settings > Advanced and enable Exchange Web Services logging for the problematic account?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    When the error reoccurs, please go back to the advanced settings window and submit the logs to us using the “Send logs” button. Please submit the logs to my email mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul

I cannot seem to send them with eM Client - it just fails each and every time I try to send with the same error as the calender sync error.  I also cannot send the logs individually as my OWA won’t allow attachments of that size.  I have compressed them to a logs.zip file to and sent them to the email address specified