High CPU use

I have a fully-updated version of eM Client and for some reason it is producing very high CPU use.  At all times it is maxing out one of my four processors, and over time it will max out a second and a third.  At this point I restart eM Client and the cycle temporarily resets.

I have determined that this is an issue with eM by reading the cpu usage by the “MailClient.exe” process in the task manager, plus observing the fall in CPU usage when the program is closed.

I thought this was perhaps some long indexing job, but the problem only appears to get worse over time.  

Anyone have any idea what could be causing this?  

Can you upgrade to the latest version available in the Release History and see if there is any difference.

I have updated to the latest version as requested and am seeing no change.  MailClient.exe is currently using 50% of an 8-core machine and has been holding there for hours.

Most of the time mine is sitting at 0% CPU usage and 160MB memory. When it does use the CPU it does not seem to go above 1.7% though I am sure it has and I just haven’t observed that. Certainly doubt it has gone as high as 50% and never continuously. That is on Windows 10 build 18363.752, so fully updated with the latest .NET. I am also using the latest eM Client beta, and the database is on an M.2 SSD. You can download an earlier beta from the Release History if you want to give it a try.

But with your current installation, if you go to Menu > Tools > Operations, is there something going on?

Maybe start that version of eM Client with a blank database and see if there is any difference. To do that close eM Client, then rename the C:\Users\yourusername\AppData\Roaming\eM Client\ directory. You may have to enable hidden items in Windows Explorer to get there. After restarting eM Client, add your email account again and see what happens.

Perhaps my problem is related to this. When the database backup runs it consumes 100% of cpu on my 4-core Intel. I am fully updated, and this has been going on for a week or so, approximately.

I monitored the backup and mine mostly it sits at 5.3% with a few spikes to 18.7% and 19.2% in the second half of the backup. What it does is combine the temporary files with the data files and then zips them. Zipping probably more than anything uses more CPU.

The OP says they have an 8 core CPU, so this is a more recent computer that probably has quite good hardware. If they are using an old-style mechanical hard disk, I don’t think that the backup would run continually, but it would take longer. Best it to first look in Operations and see what the application is doing. 

I have a SSD, and eM is using it.  I haven’t tried any of the solutions in your last comment, but will try today.  Today I woke up and when I sat down at my computer MailClient.exe was using 90% of the processor, sustained.  It still is.  I will try to mess with the database and report back.

I wonder of you uninstalled eM Client, then downloaded and installed the latest from the Release History, if there would be any difference. So not just reinstalling, or upgrading, but actually uninstalling first.

I monitored when backing up using latest V8 Beta and my CPU usage for the mail client is averaging between 8% -13% with the odd spike up to 18% - 20%. When finished back down to 0% idle. I have a 4 Core i7 8mb cache , ssd drv & 8gb ram.

Hopefully as you said Gary the latest EM Client release might make a difference.

I suspect what was going on here was that i’d had my computer on for a couple of months and Firefox had a large memory leakage over that period. Seems that eM Client can’t take that into account. I’ve since rebooted and the latest backup went smoothly.

I have taken your advice and have completely uninstalled eMClient, including removing the database, and then re-installed from the latest version.  I reconfigured my email account and it went and downloaded all my messages again.

MailClient.exe’s CPU usage is at 37% and has been for several hours.  It rose to this level more or less immediately and hasn’t backtracked at all.  

I do not believe this was a fix.

Can you turn off conversations (Menu > View > Conversations) and see if there is any difference in the CPU load?

I am wondering if EM Client is possibly still processing mail in the eg: “All Mail” folder somewhere, and so the CPU is still high because of that. This is common with a new Gmail IMAP account or similar IMAP account with a lot of emails. When you click on All Mail folder, click “Refresh” at the top & then click on “Menu / Tools / Operations” and see if anything is processing.

I noticed that with the beta 8.0.1266 with Rules and Conversations enabled, eM Client begins a sync that lasts for hours, even though there is nothing to sync, then stops and returns to normal. If I disable Rules and Conversations, the sync is normal after restart. If not, the sync continues for hours after restart. 

With 8.0.1268 this does not happen.

This is just one of the idiosyncrasies with betas.

Don’t know why, without seeing the log, why this would be happening in version 7.

Yes as you said Gary that is strange with V7 to be happening.

I have turned off Conversations, restarted emClient, and am seeing no change in behavior.

The process is quiet for a time, and then MailClient.exe suddenly jumps to 25%, 50%, or 75% of total cpu available and sits there indefinitely.  I assume it will hit 100% in time.

I am using this with a Gmail account.

What happens if you remove the Gmail account?

Go to Menu > Tools > Accounts and click on the General tab for that account. Scroll down to services and untick IMAP. That will disable the account. You will not see the folders.

You can then see if there is any difference in the CPU load after restarting.

To enable the account again, just tick the IMAP service.

My PC has exactly the same problem as everybody with eM Client on Windows 10, but the maximum CPU hogging is around 30%.

Fwiw, I just switched to emClient and imported a ton of mail yesterday on MacOSX 10.15.7, and am seeing very similar behavior: last night it pinned the CPU to 600+ percent. I killed it after a whle, but when I restarted it did the same thing. I then assumed it was indexing or something, so let it go all night; still at that level in the morning, so I killed it again. It had up a notice of an appointment from a few weeks ago (which I don’t remember at all), so I’m guessing it was doing something with iCloud Calendar sync, which I’ve now turned off.

Hi, has anybody discovered a solution to the high CPU issue? I experience this on all my Windows 10 machines. (25% plus CPU; and on one low performance machine - around 50%)