Help with Google 2-Factor Authentication

Every two weeks, my Google login is set to ask for my credentials - I use 2-factor authentication. So I can get as far as entering my unique code and submit, but then I receive the following error:

"You’ve reached this page because we have detected that Javascript is disabled in your browser. The page you attempted to load cannot display properly if scripts are disabled.

Please enable scripts and retry the operation or go back in your browser."

Problem is, eM Client - or Google - is spawning the login window when eM Client tries to go get my mail (upon opening the application, for example.), and there is no way for me to tell which browser is being used.  Which is it? All three browsers on my machine should have Javascript enabled.

eM Client version 6.0.23421.0, running Win 7 Enterprise

eM Client uses Internet Explorer for this. But lately the JavaScript issue happens even on machines where JS is enabled in IE.
This is a known problem that we are trying to solve at the moment.
Thank you for your patience.

To enable your account for now you can use a workaround that another user came up with >…
But we do realize this is just a temporary workaround and we try to locate the root of the issue.

Best regards,

I am on the trial for emClient and am seeing an identical issue. I have checked both IE and Chrome and both have Javascript enabled on my side. Same version of em Client as you: 6.0.23421.0. However, my laptop is running Windows 10 and the anti-virus I have in place is Bitdefender Endpoint Security. 

The installation is running into a different issue on my Desktop, running Windows Server 2012R2, where after I enter my Google Auth code, it simply goes to blank white page.

@Olivia Rust: While that workaround may work, that is a terrible way to get things working. Requiring to disable two-factor authentication is not something I feel comfortable with. Especially given the fact that a lot of a mobile authenticators (blizzard, authy, etc.) have the requirement of the same. Even forums (like emClient) are using authentication integrated with Google authentication.

Hello Akshay,
I agree that it’s not an ideal solution, but I felt that offering a way to get the gmail working (even if you’d have to disable 2-step verification for maybe a minute) is better than nothing.
I am sorry for the inconvenience, but as I mentioned, we did not manage to find the root of this problem yet. We will release a fix or correct solution as soon as we have it.


I understand and apologize if that sounded like an attack on you. I am hoping for a quick fix for this issue so that I can give em Client a fair shot during the trial period of 30 (now 29) days.

Almost everyone I know uses gmail (which is a lot of people) and is highly dependent on it. They cannot even think of not using 2-factor authentication on it. Possibly give people an option to use ‘application specific passwords’ instead of the 2-factor authentication? I have Outlook, Mailbird, Postbox functioning well with ‘application specific passwords’.