Help! Can't set up iCloud Calendar in eM Client

Hoping someone can help… I’m just trialing eM Client after being an often-times frustrated Outlook user for many years. So far I really like it… However, I’m having trouble setting up my iCloud calendar on it so I can synchronize calendars between my iPhone and laptop.

I’ve followed the instructions on your website - but am having no luck. I’m always getting an “IMAP AUTHENTICATION FAILED” pop-up, even though I’ve carefully followed your instructions numerous times. I use two-factor authorisation with my iCloud account and carefully type in the correct passwords. All I want is my iCalendar and my iContacts - not mail. Yet when I see the account in eM Client, it only shows ‘mail’ under the account heading. 

I don’t use calDAV, and instead are using IMAP as shown on the website instructions. I’ve tried different passwords, user names etc, and still no joy. 

If I can get this sorted, I’ll happy pay for the full version, as apart from this, it ticks all the boxes for me.

Looking forward to hearing of a solution! (Hopefully I’m making a newby mistake that’s easily rectified!)


You can add the calendar separately from the rest of your iCloud items. That would avoid IMAP and the IMAP error you are getting.

In Menu > Tools > Accounts, add a new account with + and select Calendar > iCloud Calendar.

The same for iContacts.

Thanks Gary. Does that mean I have to have a CalDAV account set up? Because that’s what it asks for. I would’ve thought I didn’t need calDAV?

Yes, that’s right. It uses CalDAV for the calendar and CardDAV for the contacts. You can set them up both as one account, or individually if you have them on separate iCloud accounts.

Sorry if I sound technically challenged, but how do you set up CalDAV/CardDAV? I thought using iCloud negated the need to use other protocols. Thanks heaps for your prompt replies btw!

If you add an account as above and select iCloud Calendar, the application will set it up as CalDAV. All you need to do is enter your email address and password and the rest is done automatically.

The final screen will allow you to also select contacts and that will be setup automatically using CardDAV.

Do I need to set up a calDAV account separately? Because when I set it up as above, it says calDAV authentication failed, so I presume I need to set this up prior?

Sorry, it actually says ‘password required for CalDAV’ and the server says ‘Unauthorized’.

Try disabling two-factor authentication on your Apple account and see if that works.

Hi Gary - thanks for your help. Unfortunately disabling two-factor authentication doesn’t work either. I’ve tried without it, with it and without it again, and still get the pop-up box saying “Password required for CalDAV” “Server says unauthorized”. There are no other calendar folders listed in Calendar except the local one when I set up the account - which I presume is because it’s ‘unauthorized’.

I used to have sync between Outlook and iCloud, so not sure why this isn’t working - although I’ve never worked with CalDav etc before.

I thought maybe you had not created the app password in iCloud’s two-factor, that is why I asked you to disable it.

Are you sure you are using the correct email address / password combination?

Yep - 100%

Have a look at this page:

Seems eM Client users were able to solve the problem.

Hi Gary - sorry for the delayed reply. Thanks for all your help - that did it! Problem solved… :slight_smile: