Hang When saving attachments

Sometimes when I try to save attachments, the whole eM Client hangs up before the save occurs or there is any option to choose a save location. The only option is to end the Client such as through Task Manager. It will restart OK, but only after several minutes of checking the database. Another attempt to save the attachment is quite likely to hang again, but not always, it’s  unpredictable. I’ve tried different ways of saving the attachment e.g. with email open or in preview etc but haven’t pinned down a pattern here. Sometimes a complete restart of Windows will clear so it starts working, but sometimes not.  It’s very long winded to test due to the database check every time.
eM Client version 7.2.36694.0

Uninstall eM Client, choosing NOT to delete the database when prompted, then download and install 7.2.35595 from the Release History.

This problem should soon be solved.
Somebody on this forum mentioned a version 7.2.36775.0, which is not yet in the _ Release History _. But anyway, I managed to download and install it and it works perfectly. I just tried saving attachments from 6 different mails. The biggest one was an email to eM Client support with 152 (.log) attachments worth 6.5MB alltogether. No crash, no hangs.

Glad you worked out how to download it. :wink:

It has already been pushed to some users, and I am using it myself. I guess it will be on the Release History soon.

It’s not exactly rocket science.

You would think so, but . . . . !!

If you download eM Client from https://www.emclient.com/download, you get 7.2.36775. 

But since all eM Client versions have the same name “setup.msi”, you only find out what you have after downloading the file, if you don’t use the Release History.


you only find out what you have after downloading the file

Not even then -  File properties doesn’t show the version either -being a  .msi file.
Not even when you start the installation…and then only if you click Details
in the UAC confirmation panel.
If you have turned off UAC, you won’t even get that.
What’s with the file version hiding baloney ?

Yes, you can at least see from the release date in the details tab if it is newer than the last version in the Release History (see screenshot)_. _Don’t get confused by the file name, I rename that myself during download.

Thanks everyone for their help.  Pefunk, I guess you had the same issue?  Sometimes the downloading works fine for me but then it will suddenly refuse to work. Anyway I’ll download that new release and give it a go. 

No, I didn’t have any issue at all with version 7.2.36694.0. i am just an old-age pensioner with too much time on my hands, so I spend a lot of time experimenting. And I don’t receive many emails with attachments that are worth saving. So, if there was a bug, it didn’t concern me.
I just wanted to point out that rather than move down to an older version you could also move ahead to the latest, at that time still “hidden”  version.

… and it is still not in the Release History

Just checked and won’t be for a while  lol  

Don’t get confused by the file name, I rename that myself during download.

Yes, since you knew in advance. I do too for other software where  they have put  this near the Download button.
That’s too difficult for eMC and  makes too much sense  rofl

I do it during install ,while it’s halted for UAC -copy the version and rename
the setup.msi   Since  “setup” is  being edited ,I  overwrite it with the version .
You can call it anything.I haven’t tried virus yet  lol - to see if it gets flagged…

Just to confess my ignorance. what is UAC?

UAC = User Account Control

Benutzerkontensteuerung BKS?

Thank you. I always click on “yes” immediately. Never noticed the headline “Benutzerkontensteuerung” or the option “weitere Details anzeigen”.

Yes ,most people do and end up with malware if the AV app doesn’t catch it.
Anyway UAC has it’s uses…

Making backups ? Nah, too much trouble - I’ll be OK
Trying an unknown app in a “sandbox”?  Same answer.

People do what they want to do regardless of consequences