Google contacts will not sync

I have never been able to get Google contacts to sync with EMClient over the last four years and If this can’t be solved I will have to find another email program.

Hello Derek,

Please make sure that it Menu > Tools > Accounts > your Gmail account > Services you have the option “Google Contacts” ticked.
If so, please make sure that on your Google Contacts settings, the synchronisation is allowed.

Russel

Everything you suggest is OK, but I find that in Menu/tools/contacts that Contacts is not connected to my email address (but my email service is working perfectly).
This is the message I get:-
“Connection Failed
An attempt to connect to dbird056@gmail.com failed. This could be caused by temporary server unavailability or incorrect settings. Please check the settings or click on the warning symbol to try connecting again.”
The settings are all correct in Emclient, in Google and in Windows 10 and since the email is OK it can’t be anything to do with the server.
I really am tearing my hair.
Regards,
Derek Bird