Google contacts - synncing doesn't work

Hello,
when I created contact within the Google contacts it is not synced to the G-Maill. I got the error
[Google Contacts]Nahrávání položek do složky ‘xxxxx@gmail.com/Contacts’ selhalo kvůli následující chybě: Execution of request failed: https://www.google.com/m8/feeds/contacts/default/full (Invalid request.)
The error ocours for last cca 1-2 weeks, not before

`

Sometimes the easiest way to deal with Google errors is to just remove the account from eM Client, then add it again. Mostly that solves the problem

Excuse, I forgot mention - i already did it. *removed the accout, i checked any way to acces eg. IMAP, G-Mail clien, …

@hrbekma See this EM Client Support article which might fix the problem for you.

Google Contacts Error, Execution of request failed: https://www.google.com/m8/feeds/contacts/default/full (Invalid request.) - Powered by Kayako Help Desk Software (emclient.com)

@hrbekma For Gmail Contacts before I click “New” to add a contact, i always make sure i highlight “My Contacts”

Also when you dblclick / open the contact in EM Client you can also change which Tag / Contact Folder its located in (for exiting Google contacts) which will then Sync to Google Contacts in the same Tag / Folder online.

image

1 Like

Thanks, the prob is realy with the flags. Unfortunately I did not solve it, I can use just workarround. eM client uses the own set of the flags which differs from the Google ones. The error occours in case I create the contact without flag. So the WA is to use any flag in eM.

The default folder/label/tag for Google Contacts is My Contacts. Just create your contact in that folder and it will sync without error. You don’t need to assign a tag - it will be done automatically.

Saying that, I don’t add tags to my Google Contacts and they sync just fine even when they are not in the My Contacts label.

Right, thanks. I don’t use tags also. So thats why I used root folder Contact in eM.

If you create the contact in the root folder, it should still sync without error.

The only issue with that is when viewed using the web interface for Google Contacts, they don’t show in the Contacts section. You will find them, however, in the Other Contacts section.

I don’t know if this is an issue with the Google web interface, because the same contacts in the Other Contacts section sync just fine to my phone and are included with everything else there.

I have a similar issue, however using the German version.
After setting up emClient withthe gmail account, there’s no “My Contacts” folder, but all contacts imported from gmail have the tag “My Contacts” added. Interestingly this tag isn’t available for new contacts I create.
The main folder is called “Meine Kontakte” and one of the subfolders is named “Kontakte”.

If I manually add a folder or tag with the name “My Contacts” (somehow emClient creates a folder if I add a new tag “My Contacts” to a newly created contact) those contacts apear in gmail web in a newly created label “My Contacts” and still not in the main “Contacts” section of gmail web. I have to manually click the “Create as contact” button in gmail web for every new contact I create in emClient so it appears on the phone.
BTW: Contacts in the “Other contacts” section in gmail web don’t appear in the phone, nor do birthdays appear in the corresponding calendar of gmail.

Any solution on how to fix this, so contacts are synced correctly without any tedious workarounds?

When you create a contact in eM Client, create it in the My Contacts folder.

As I wrote above, the result is that this new entry from emclient appears in gmail under a new label “My Contacts” and is not in the list of all contacts. I have to manually click the “Add as contact” button for every new contact I create that way. Thus I need to open gmail web client everytime to make it work.
This is not a solution for me, or better for my father who is actually using this – I just do the support and try to find a solution.

BTW: The “My Contacts” folder is not created automatically in emclient. There was just a tag set, without actually creating the tag, so I can’t even tag the new contacts with the label the imported/synced ones have.

I am not able to reproduce that.

In eM Client, if I create a new contact within the My Contacts folder, it automatically syncs and appears in the Contacts section of Google Contacts in the web interface. It will not create a My Contacts label in the web interface, just saves the contact in the Contacts section.

You need to make sure when you create or save the contact in eM Client, you are choosing the correct folder. The tag will automatically change, but just make sure you choose the correct folder.

If you have created your own tag called My Contacts, edit your tags and remove it.

It should be because it is a Google System Folder. It is hidden in the current web interface, but the server passes that information on to eM Client, and eM Client displays it. If it is not being displayed in eM Client then there is some error. Go to Menu > Operations and look for any Contact errors in the Log tab.

I just created a new Google Account. When I added it to eM Client, these are the contact folders it automatically displays:

image

When I created a contact in eM Client, in the My Contacts folder, it correctly displays in the web interface in the Contacts section without creating a My Contacts label.

When I create a contact in the top-level Contacts folder in eM Client, it is displayed in the Other Contacts section of the web interface and that folder automatically syncs to viewable contacts on my Android phone using default settings.

Hi and thanks for the effort. I removed the gmail account and recreated it again. Here’s how it looks like.


The “Meine Kontakte” folder is probably translated due to the german version, but the location in settings is also named “Gmail/Contacts/Meine Kontakte”. This folder is empty. All contacts are in “Contacts” which has a location of “Gmail/Contacts”, and they all have a tag “My Contacts” which is not really created in emClient. So I see it, when I open an existing+tagged contact, but when creating a new contact, I can’t choose this tag.
Again: If I create it, it appears in Gmail as a new Label named “My Contacts” and I have the manual trouble again.

I wonder if this is not an issue with the localization in either eM Client or Google. In other words, the use of Meine Kontakte rather than My Contacts.

Whichever way I try it, with eM Client and Google set to English, it works exactly as I have described.

I suggest that if you have a Pro License, you open a support ticket with eM Client.

@kassi as @Gary advised above that when you add a new Gmail contact into EM Client via (Contacts) at the top, it will normally only show in (Other Contacts) at the Google Contacts (Online).

However if you then open that contact in EM Client and change the Tag / Label to (My Contacts) and then Re-Save the Contact as per the below example, it will then show in Google Contacts (at the top online) and no longer be in Other Contacts online.

So this is why I always Tag / Label any new Gmail Contacts in EM Client straight into “My Contacts” from the start.