Gmail rejects sign-up attempt after update and registration

A few days ago I downloaded eM Client and it worked well with gmail and another email account. Late yesterday (8/27/15) I got a message to update the software and I did so. I first tried it today after reboot. It didn’t work work because it says I need to register, even though I am still in the 30 day trial period.  I did the free registration and entered the code. It gave an error message saying it couldn’t contact either of my accounts. I ran the diagnostics in the tools>settings menu and it connected ok to one account but not to the gmail account (it acts like the password is bad but it isn’t). Then I get a message from gmail saying “Someone just tried to sign in to your Google Account wplcarter@gmail.com from an app that doesn’t meet modern security standards.” I can sign in and get email from my other account, which is wpcarter@ucr.edu. Help shows the current version as 6.0.23181.0.

Until this happened it seemed to me that eM Client may be a good option now that I’m forced to abandon Eudora, and I was planning to get the “Pro” license if it continued to be satisfactory. I hope this can be easily resolved.

  • Bill Carter

Hello Bill, sorry to see this, can you please make a screenshot of the error that was thrown by the application, when you updated the application, or are you unable to replicate the problem?

We experienced a slight server downtime issue, I’m afraid this might be related, but please make sure to let us know if the issue persists.

Regards,

There is really nothing to show. The gmail server is just rejecting the login attempt and eM Client is interpreting it as a bad username/password combination. However, the password is good and I got emails (to my primary, non-gmail address) from Google stating that a login attempt was rejected saying that I am using an “app that doesn’t meet modern security standards”. I imagine you have seen these email messages from Google before from other users. It doesn’t provide any more information than that, but the fact that I got this message means that Google is associating these login attempts with my gmail account. Running diagnostics in your “accounts” screen doesn’t help - it finds the server but says it is rejecting the login and asks for a new username/password. I can send you screen shots of the diagnostics system stating this and the email I got from Google but I don’t know how to enter screen shots into this message (I’m new to your system).

The “IMAP” tab in the “accounts” display shows the host as imap.gmail.com, port 993, security policy "use SSL/TLS on special port (legacy). The “SMTP” tab shows the host as smtp.gmail.com, port 587, Security policy “Force usage of SSL/TLS”. This is what your “diagnostics” tool came up with. Making manual changes to these don’t seem to help, though I didn’t try all combinations.

Hello unfortunately I have not seen these messages from other users, please make a screenshot of the error for more information. eM Client is using OAuth 2.0 to authenticate with the server, this is the current “modern security standard” used by Google which has been implemented into eM Client for authenticating with Google’s servers specifically.

If you’d like to resolve this issue, please share more information about this error - is it thrown in the Operations window or do you receive an email message about this from Google?

Seems a bit odd that one of your accounts hosted with Google is working properly and the other doesn’t don’t you think? Or is the second account hosted on a different email service? Are you using any security software on your computer?

Regards,

As stated previously, the problem shows up within eM Client as if I gave a bad password when I run the “diagnostics” from tools>accounts, then I get emails from Google (through eM Client!) that I attempted to log on with an insecure client. I just found out I was able to apparently “resolve” this problem by going to https://www.google.com/settings/security/lesssecureapps when logged onto Google and selecting “turn on” for “accessing less secure apps” (I found the link in the email Google sent). But that doesn’t solve the problem of Google acting like your app is “less secure”, while you say it meets their standards.

But then I found that I could actually send and receive emails through eM Client using my gmail account even after I “turned off” accessing less secure apps after I turned it on.  Maybe it was working all the time but I thought it failed because I got an error message about being unable to connect after I installed the new version and found the diagnostics in tools>account consistently failed until I found out about “turning on less secure apps”. So I didn’t actually test sending and receiving emails through gmail until I got the diagnostics to work. After I “turned off” less secure apps, the diagnostics failed again but I was still able to send and receive emails using my gmail account. Maybe that’s why I was able to get the warning emails about sign-in attempts from Google. Or maybe Google is remembering that I allowed this app before and my turning off allowing insecure apps is only applicable to my next attempt with another app?

Am I REALLY the only user of version 6.0.23181.0 that is having this problem of Google acting like your app is not secure enough when the diagnostics are run? Maybe I’m the only user who has “upgraded” to this latest version when I found it was available a few days ago who ran the diagnositics. It worked fine before I upgraded, and maybe most of your other users are still using earlier versions of eM Client. I suggest you test the diagnositics yourself with this version, if you haven’t done so already, making sure that you have “accessing less secure apps” “turned off”.

I am using Windows 7 Professional (Version 6.1, build 7601, service pack 1) with BitDefender Internet Security 2015, if this makes a difference.

I am now getting this issue. Google reject login for my Gmail account.Received email that rejected and “an app that doesn’t meet modern security standards.” thus login rejected. So frustrated.

Hello, unfortunately not quite sure why this occurs, eM Client’s latest releases (since April) is using OAuth 2.0 as the main authentication method to authenticate with the remote server. Make sure you’re using the latest release and check if you’re able to login - 6.0.23330.0 - using this authentication, you should be able to manage connected apps in your Google account settings where eM Client should be shown after you authorise the app via OAuth.

Here is the message from Google. This is happening to me also.

Hello David,
are you using the latest possible version of eM Client? Having your gmail sign in using oAuth should remove this issue and it should be implemented in the latest eM Client.

Best regards,
Olivia

I just started experiencing this problem today as well. I am running eM Client 6.0.23421.0

I deleted my GMail account from eM Client, closed the program, and then added it back in, and it worked. However, I noticed that if I go into TOOLS > ACCOUNTS and click the Diagnostics tab for my GMail account and then click the Diagnose button, I get the error again and it prompts me for a password. After repeatedly entering the password (and it getting rejected), both the IMAP and SMTP tests fail.

But the odd thing is I can still send and receive email without any issues. So it seems that the Diagnose function is where the problem lies.

Hello Michael,
the Diagnose function is literally just trying to login to google’s servers directly - that means that a third party application is using your credentials - which is something Google recognizes as ‘less secure’ behaviour.
The secure login that is now recognized is only oAuth - that means when you add your account, instead of eM Client getting your credentials and sending them to google, a browser window will open and you will send the credentials only to google yourself, granting access to your email to eM Client (but not giving out your password). The diagnose function asks for credentials because the application no longer stores them.
We disabled the Diagnose function for gmail in v7, and to avoid this problem in v6 with attempted sign ins just don’t use the diagnose function.

Best regards,
Olivia

OK. So just recently started having this issue. Keep getting pop ups failed to connect - and google rejects the sign in. I understand Olivia’s most recent answer and em client still works for me - but is there a way to disable the constant pop ups telling me it can’t connect?