GMAIL "Please enter username and password".

I’m stumped. I recently started using eM Client and was surprised that the home version is free! Everything worked fine until I reset my laptop. I went to Google 2 step verification and generated a unique password for eM Client, it synced my mailbox beautifully the first time but now I get the above message.
What did I do wrong after I reset my laptop for this to happen.

Windows 8.1
Gmail with 2 step verification

Hi, have you used the two step verification password with eM Client. Usually the gmail generated password is a long hash code specifically generated for the application, you have to use this password instead your regular password in eM Client? Did you change the passwords in your account settings?

Thank you,
Paul.

Hi Paul McGregor and thank you for the answer. I have 2 step verification enabled on GMAIL. As you can see in the screenshot I manually added a unique app password for eM Client. What is interesting though is that it tells me the last date I used it, which is today, and I have not used it. I fired up my laptop and opened eM and promptly go the message that Gmail cannot log in.

More screenshots:
1 I went back for Google 2 step, revoked my eM client password and created a new one.
2 I used the new (very long) password to log into eM Client.

Myst I now change it back to my normal gmail password?

Hi, sorry for my belated reply, this looks like everything should be working while using the app specific password.
Did you copy/pasted the password into eM Client from Gmail’s website (are you completely sure you’re using the correct password)?

Can you possibly try to create the account again using the 2-step verification password in the automatic setup?

Before you do that, maybe try to access this gmail account setting: https://www.google.com/settings/security/lesssecureapps
and try to enable the access for less secure apps and check if the issue persists.

Thank you,
Paul.

Hi Paul and thank you for helping, its 9 days later and Im getting to this only now. Here are your questions and my answers:

Did you copy/pasted the password into eM Client from Gmail’s website (are you completely sure you’re using the correct password)?
       * Yes I copy pasted a few times to make sure it is correct.

Can you possibly try to create the account again using the 2-step verification password in the automatic setup?
      *Not sure what you mean by creating account again? Do you mean I must remove it from emClient and add it back using a new 2 step verification number?

Before you do that, maybe try to access this gmail account setting: https://www.google.com/settings/security/lesssecureapps
and try to enable the access for less secure apps and check if the issue persists.
     * It tells me the following :“This setting is not available for accounts with 2-Step Verification enabled”.

Hi again, based on your answers please try to re-add the account into eM client, unless you’re currently using two accounts (maximum number for free users), you don’t have to delete the account yet, just add it again by selecting “New account” in the accounts settings and if the setup is successful, you can remove the previously setup account.

Thank you,
Paul.

Paul McGregor, I just came back here to say thank you. I removed the 2 step verification from my Goggle account and my 1st gmail address is now working. It is a pity though as I would like to keep the 2 step verification. The 2nd Gmail address still ask me for a password the whole time but, I see someone logged the same problem very recently. I will keep an eye on his post for a while and see how it gets answered. I really dont want to move to another email client as eMclient is really good. I especially like the way I can create folders and then drag an drop into them.

I’m willing to pay for the Client if I can be assured someone will help me set it up with 4 Gmail addresses using Google 2 step verification.

I manage t set up a Gmail addie, with 2 step, by generating an app specific password in Google. It does not last long though before I start getting pop ups again requesting a username and password again.

Drats!!

Are you using any firewall/proxy software on your computer? Did you try to re-add the account as I previously suggested?

Thank you,
Paul.

Hi Paul. Just the normal Windows firewall and no proxies I know of. I’ve disabled my Google 2 step notification, added the same Gmail account to eM without removing the previous one. None of these work. I still het a message to enter password. I think, get the feeling the problem lies with Google.

Hi again, can you please send me an email to mcgregor@emclient.com with a reference link to this forum topic?

Thank you,
Paul.