gmail not connected to server

I’ve been using eMClient for a few months now and have had no problems with it. I prefer to use it instead of my online Gmail account. But all of sudden I keep getting an error stating that eMclient cannot connect to server. I haven’t made changes to any setting or authentication information. I’m able to log into my account online without an issue. I uninstalled and reinstalled the program and continued to get the same error. Can someone help me with this?

Hi Taria,
when the error pops up again, could you click the third tab in the same window titles ‘Log’ and copy it’s contents here?

Regards,
Olivia

I had issues with Windows 10 install and had to use the Google generated “App Password” to configure the client because em Client was calling Microsoft Edge, which does not support Java used via the 2 factor authentication.  I have the same issue now, while trying to add the google calendar

Hi Mick,
since Taria doesn’t mention any Javascript error, the issue might be a different one, that’s why I’m asking for a log data first.
I replied to your post about the JavaScript error, that one is a known problem and we’re working on a fix.

Regards,
Olivia

Hi Olivia, 

Here is the information you asked for. 
10:14:53 AM Online state: changed to online due to NetworkAvailability 10:14:53 AM tcwill0982@gmail.com [IMAP]  Synchronizing subfolders: For folder tcwill0982@gmail.com/
10:14:53 AM tcwill0982@gmail.com [GData]  Synchronizing folder list
10:15:14 AM tcwill0982@gmail.com [XMPP]  MailExceptions.ConnectionException: 
10:15:14 AM (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond [2607:f8b0:4003:c0d::7d]:5223)
10:15:14 AM tcwill0982@gmail.com [GData]  Synchronizing folder list

Also, yesterday I re added my Gmail account and this morning the newly added account had updated and I was actually able to save a draft and it synchronized as expected. But then all of sudden I received an error. I removed the account that I originally added and restarted the program. The information above is from the newly added Gmal account (which is really the same as the original, but I’m getting the same error). Hope that makes sense. Thanks for the quick response. 

Taria

Hi Taria,
seems like some other program could be blocking the connection, can you try making an exception for eM Client in your anti-virus software and windows firewall if you use them?
If this doesn’t help, could you copy the full message of the error as well? (or take a screenshot of it)

Regards,
Olivia

Hi Olivia , 

I made sure my windows firewall had an exception for eM Client but that didn’t work. Here is the full log

12:00:37 PM Online state: changed to online due to NetworkAvailability 12:00:37 PM tcwill0982@gmail.com [IMAP]  Synchronizing subfolders: For folder tcwill0982@gmail.com/
12:00:37 PM tcwill0982@gmail.com [GData]  Synchronizing folder list
12:00:58 PM tcwill0982@gmail.com [XMPP]  MailExceptions.ConnectionException: 
12:00:58 PM (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond [2607:f8b0:4003:c10::7d]:5223)
12:00:58 PM tcwill0982@gmail.com [GData]  Synchronizing folder list
12:01:07 PM tcwill0982@gmail.com [IMAP]  Downloading message part…
12:01:20 PM tcwill0982@gmail.com [GData]  Synchronizing folder list
12:01:20 PM tcwill0982@gmail.com [GData]  Synchronizing folder list
12:01:20 PM tcwill0982@gmail.com [GData]  Synchronizing folder list
12:01:20 PM tcwill0982@gmail.com [GData]  Synchronizing folder list
12:01:21 PM tcwill0982@gmail.com [GData]  Synchronizing folder ‘tcwill0982@gmail.com/Contacts/’
12:01:21 PM tcwill0982@gmail.com [GData]  Synchronizing folder ‘tcwill0982@gmail.com/tcwill0982@gmail.com/’
12:01:37 PM tcwill0982@gmail.com [IMAP]  Downloading message part…: Done
12:01:37 PM tcwill0982@gmail.com [IMAP]  MailExceptions.ConnectionException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. —> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. —> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
12:01:37 PM    at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
12:01:37 PM    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
12:01:37 PM    — End of inner exception stack trace —
12:01:37 PM    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
12:01:37 PM    at System.Net.FixedSizeReader.ReadPacket(Byte[] buffer, Int32 offset, Int32 count)
12:01:37 PM    at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
12:01:37 PM    at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
12:01:37 PM    at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
12:01:37 PM    at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
12:01:37 PM    at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
12:01:37 PM    at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost, X509CertificateCollection clientCertificates, SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
12:01:37 PM    at MailClient.Imap.Base.Connection.<>c__DisplayClassa.b__9()
12:01:37 PM at MailClient.Imap.Base.Connection.Connect(Func`1 getStream)
12:01:37 PM at MailClient.Imap.Base.Connection.Connect(String receiveHost, Int32 receivePort, Boolean explicitSsl)
12:01:37 PM at MailClient.Imap.ConnectionPoolEntry.Reconnect()
12:01:37 PM — End of inner exception stack trace —
12:01:37 PM at MailClient.Imap.ConnectionPoolEntry.Reconnect()
12:01:37 PM at MailClient.Imap.ConnectionPoolEntry.Connect()
12:01:37 PM at MailClient.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore)
12:01:37 PM at MailClient.Imap.Synchronizer.DownloadCommand.ExecuteInternal(WorkerStatus status)
12:01:37 PM at MailClient.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
12:01:37 PM at MailClient.Commands.Command.Process(WorkerStatus status)

Hi Taria,
the error claims that " An existing connection was forcibly closed by the remote host." which means it’s either another application or server itself blocking your connection.
Are you really not using any anti-virus software?

Regards,
Olivia

Hi Olivia, 

It looks like everything is working fine now. Not exactly sure why. But I was incorrect I was running Norton antivirus. I appreciate all of your help and will let you know if the error occurs again. 

Taria 

Good evening, once again, suddenly, it stopped working? Why all these problems with Gmail! Still server problems? Kind regards.

Hi Perrin,
if you check the date, this thread is from the time the error was still actual.
The new update fixes it.

Regards,
Olivia