Gmail Label "spam" not showing up in EmClient(current version)

The Gmail “spam” folder does not show up in Emclient. I have the Gmail labels configuration set to “show in Imap” and the spam label is checked as well.  I have rebooted EmClient after checking the Gmail config .  What else can I check or configure to be able to see the spam folder?

Hello Kyle,
go to Menu>Tools>Accounts and under IMAP tab check the what the Special folder for Junk is set to.
Also, is there perhaps a second ‘Spam’ or ‘Spam mail’ label in the webmail settings? Go to Gmail and look into Settings>Labels.
Post screenshots of the full label list if you are unsure, please.