GMail IMAP Error: Not accepting credentials

New eM Client in October 2014 - Reviewed all blame and solutions proposed

  1. Followed all of eM Client’s instructions, then X
  2. Specified
  3. Narrowed choice to mail and imap (worry about calendar, task and contacts later)
    Still nothing, and believe it or not work seamlessly with Outlook / Exchange - Go Figure
  4. Followed all of Gmail instructions with other
    Tried port, fiddle with every item once including logging in and out over 3 hours
    5 First thing that works, which seems to irk eM Client is setting Gmail to “Allowing less secure apps” which in the end would be unacceptable. I’ve been hacked twice this year, for unknown reasons.
    Tried for another hour per eM varied community suggestions
    6 Went back to Google and Gmail, set up instead 2 step verifications.
    Nada, nothing, niet
    7 Went back to Google and Gmail, set up Application “Accounts Permission” or Mail on Windows Computer

This is solved for me, but perhaps the above can help others. But note first fix, was “less secure”. If this is not the case eM Client then you may wish to review your solution around this issue.



Hi Mike,
I’m sorry this setting has been causing some issues, unfortunately this setting essentially only allows gmail account users to use the account with an application that’s using password for authentication.
Without this setting enabled you might not be able to use other email clients either, only the ones using OAuth for authentication, OAuth is not using your password to authenticate between the client and the server but a given token - this is a more secure way of authentication but does not necessarily mean password authentication is not secure.

We’re considering improving this for future releases of eM Client, but note that even using the less secure apps option, you’re not being unprotected.

What kind of issues were you having using the two step verification process? Did you generate the app specific password for eM Client?

Thank you,


I recognize the setting goal.

But the password authentication simply didn’t work. Google’s “less secure” page option would seem to suggest otherwise but thanks for the assurance. It is appreciated.

I was trying each step successively. The 2 step after reboot simply didn’t work as suggested. And I allow for the fact that I may have been impatient or did not follow the process exactly.

I did generate app specific password yes.

As a follow on, if I may. I now get the following in errors tab, of operations window: "Deleting folder "personal email/my email list/ failed with an error: Invalid value. It doesn’t seem to impact anything but I will like to solve if you have an idea?

Hi again Mike, is this an existing folder of your Gmail account? can you try to right click the folder and select Properties > Repair and click on the “Repair” button?
If this folder is not present in the subfolder tree right click your account and select again Properties > Repair and click on the “Repair” button.

Hope this helps,