Gmail IMAP Download Offline for image and attachment does not work

Half of the reason I started using eM Client was the IMAP support, like Outlook Express, it stores the email locally. With eM Client, I have chosen selected Folder/Label with the option to “Download Message for Offline Use” and I have tick to include the image and pictures. But it seems eM Client is only download the messages, no image and attachment is downloaded. I have to do it by open the mail or attachment myself.

Hello,
unfortunately I wasn’t able to simulate your problem. Images and attachments were always downloaded. Did you wait for downloading process finishes after clicking Download Now?

Maybe we could find out more if you send us logs:
go to menu Tools->Settings->Logging and check IMAP. Then restart eM Client, try to simulate the issue and send us the logs using the same logging settings window.

Regards,

Milos Kovalcik.

I’m away from my desktop PC, so I can’t give you the log at the moment. But there’s no problem or erros. And yes, I’ve waited till all the message have finished downloading.

Later the night, I still I might got on to something, but I need more test to confirm. Will post here if I got to anything. At the moment, I’ve only installed eM Client on my parents machine (as opposed to no e-mail client in Windows7). This is the first time I’m using it myself. As I have quite a large e-mail database with complicated mail rules set on my gmail. I don’t want to mess it up. But will put more test to the program.

Confirmed. The problem lies with the “Unsafe Content” option. I was mainly importing my mass local and imap mail first, without setting any options. And the default was under “Block unsafe content in all messages”. Which were different from Outlook Express, as OE download all IMAP emails first (depends on the setting whether or not to sync), than gives you the option to see the unsafe content or not. This is obviously a design different. There’re pro and cons in both methods, I can’t argue which is better. But I do recommend adding a white/black list feature in “Unsafe Content”. This can easily be added as having a White/Black list under “Contacts”, I’ve made my suggestion here already: https://discourse.emclient.com/emclient/to…

Thanks for the quick response.

I’m new to this program but like it! However, I’m having problems with the image display. None of the images are displayed so I click the “x” to download the pics but nothing happens. Is there a solution?!

What version of eM Client are you using?

version 5.0.17263.0

Can you send me the problematic message directly at wilson@emclient.com? Thank you.