Gmail accounts repeatedly not syncing

I’ve been trying out eM Client for a few days, and noticed this on several occasions. At the moment it seems continual…

I have two Gmail accounts and one Yahoo account using IMAP, syncing email only. Sometimes they work perfectly, but sometimes not.

At the moment, neither Gmail account will sync; I just have swirly circles next to the accounts in the left pane. Sometimes the Yahoo account seems to behave similarly but not so often.

I tried clicking the Diagnose in the account setup. Other than getting a tick, nothing else happened. Out of curiosity to see if Gmail itself was working, I loaded Outlook which immediately synced with the accounts and showed a test message obviously sent by the Diagnose process in eM Client.

Still nothing in eM Client, after at least 20 minutes of swirly circles.

I have quit and restarted eM Client a few times to no avail. Having said that, I just restarted it again and this time one of the Gmail accounts seems to have synced quickly, followed after about a minute by the Yahoo account. But my main Gmail account still won’t sync.

The Gmail settings for IMAP are “imap.gmail.com”, port 993, “Use SSL/TLS on special port (legacy)”. My user credentials are of course correct. I’m not trying to do anything ‘clever’ with the accounts.

OK, I’m working as I slowly type this message up.

I just enabled logging on the gmail account. Oddly, the instant I closed the account setup dialogue, the account synced! Nothing else was changed, I had opened and closed the same dialogue several times and have been watching the swirly circles for over twenty minutes. So long I think they have started to hypnotize me!

The Yahoo account seemed to be still stuck too, so I did the same with that, with exactly the same result of syncing immediately I closed the dialogue.

I’m still going to post this as there is clearly some issue.

Finally, I recall when I first installed eM Client (6.0.19714.0) and imported my accounts from Outlook, none of the IMAP accounts seemed to work for a while. I ended up playing with the IMAP settings (not much to do really) and even resetting my passwords on the accounts just in case. Eventually they seemed to just start working, with the settings I gave above which I think might have been what they were imported as.

Any suggestions?

Wow - that was a long-winded post!

Rick.

Edit: Ten minutes later, my main account is stuck not syncing again.

Next night, and my main Gmail account is stuck again. I’ve sent it a test email message from another account but the Gmail account won’t sync and just shows the swirly circle all the time. It did sync previously because there is some new mail in there.

I loaded Outlook which immediately synced and got the test email. Ironically the poor performace on Outlook with IMAP is one of the reasons I am looking at other clients. That and the lack of a ‘all unread mail’ view which eM Client does nicely.

The log for the account ends with this, it seems to be stuck ‘idling’. Within the time frame below, I have tried sending the test email and clicked send/receive all several times:

00:09:00.531|039| + idling
00:13:08.780|01D| DONE
00:13:08.803|039| A143 OK IDLE terminated (Success)
00:13:08.803|01D| A144 UID FETCH 7929 (BODY.PEEK[1])
00:13:08.978|039| * 31 FETCH (UID 7929 MODSEQ (453615) BODY[1] {2072}
00:13:08.981|039| A144 OK Success
00:13:11.986|014| A145 IDLE
00:13:12.006|039| + idling
00:13:13.016|01D| DONE
00:13:13.046|039| A145 OK IDLE terminated (Success)
00:13:13.046|01D| A146 UID FETCH 7158 (BODY.PEEK[2])
00:13:13.146|039| * 4 FETCH (UID 7158 MODSEQ (418534) BODY[2] {8192}
00:13:13.146|039| A146 OK Success
00:13:13.146|01D| A147 UID FETCH 7158 (BODY.PEEK[2])
00:13:13.176|039| * 4 FETCH (UID 7158 MODSEQ (418534) BODY[2] {8192}
00:13:13.176|039| A147 OK Success
00:13:13.176|01D| A148 UID FETCH 7158 (BODY.PEEK[2])
00:13:13.206|039| * 4 FETCH (UID 7158 MODSEQ (418534) BODY[2] {8192}
00:13:13.206|039| A148 OK Success
00:13:13.206|01D| A149 UID FETCH 7158 (BODY.PEEK[2])
00:13:13.226|039| * 4 FETCH (UID 7158 MODSEQ (418534) BODY[2] {1083}
00:13:13.226|039| A149 OK Success
00:13:16.286|014| A150 IDLE
00:13:16.306|039| + idling
00:14:12.446|01D| DONE
00:14:12.476|039| A150 OK IDLE terminated (Success)
00:14:12.476|01D| A151 UID FETCH 7872 (BODY.PEEK[2])
00:14:12.646|039| * 19 FETCH (UID 7872 MODSEQ (448493) BODY[2] {8192}
00:14:12.656|039| A151 OK Success
00:14:12.656|01D| A152 UID FETCH 7872 (BODY.PEEK[2])
00:14:12.676|039| * 19 FETCH (UID 7872 MODSEQ (448493) BODY[2] {8192}
00:14:12.676|039| A152 OK Success
00:14:12.676|01D| A153 UID FETCH 7872 (BODY.PEEK[2])
00:14:12.706|039| * 19 FETCH (UID 7872 MODSEQ (448493) BODY[2] {4395}
00:14:12.706|039| A153 OK Success
00:14:15.866|014| A154 IDLE
00:14:15.886|039| + idling
00:14:21.756|01D| DONE
00:14:22.096|039| A154 OK IDLE terminated (Success)
00:14:22.096|01D| A155 UID FETCH 6957 (BODY.PEEK[2])
00:14:23.566|01D| A156 UID FETCH 6957 (BODY.PEEK[2])
00:14:23.976|039| * 2 FETCH (UID 6957 MODSEQ (418499) BODY[2] {8192}
00:14:23.976|039| A155 OK Success
00:14:23.986|039| * 2 FETCH (UID 6957 MODSEQ (418499) BODY[2] {8192}
00:14:23.986|039| A156 OK Success
00:14:23.986|01D| A157 UID FETCH 6957 (BODY.PEEK[2])
00:14:24.486|01D| A158 UID FETCH 6931 (BODY.PEEK[2])
00:14:25.346|039| * 2 FETCH (UID 6957 MODSEQ (418499) BODY[2] {8192}
00:14:25.346|039| A157 OK Success
00:14:25.386|039| * 1 FETCH (UID 6931 MODSEQ (418697) BODY[2] {8192}
00:14:25.386|039| A158 OK Success
00:14:25.386|01D| A159 UID FETCH 6931 (BODY.PEEK[2])
00:14:25.416|039| * 1 FETCH (UID 6931 MODSEQ (418697) BODY[2] {3628}
00:14:25.416|039| A159 OK Success
00:14:28.426|03E| A160 IDLE
00:14:29.396|039| + idling
00:14:59.566|01D| DONE
00:14:59.596|039| A160 OK IDLE terminated (Success)
00:14:59.596|01D| A161 UID FETCH 6957 (BODY.PEEK[2])
00:14:59.756|039| * 2 FETCH (UID 6957 MODSEQ (418499) BODY[2] {8192}
00:14:59.756|039| A161 OK Success
00:14:59.756|01D| A162 UID FETCH 6957 (BODY.PEEK[2])
00:14:59.776|039| * 2 FETCH (UID 6957 MODSEQ (418499) BODY[2] {8192}
00:14:59.786|039| A162 OK Success
00:14:59.786|01D| A163 UID FETCH 6957 (BODY.PEEK[2])
00:14:59.806|039| * 2 FETCH (UID 6957 MODSEQ (418499) BODY[2] {7406}
00:14:59.816|039| A163 OK Success
00:15:00.826|01D| A164 UID FETCH 7483 (BODY.PEEK[2])
00:15:00.886|039| * 5 FETCH (UID 7483 MODSEQ (418742) BODY[2] {8192}
00:15:00.886|039| A164 OK Success
00:15:00.886|01D| A165 UID FETCH 7483 (BODY.PEEK[2])
00:15:00.916|039| * 5 FETCH (UID 7483 MODSEQ (418742) BODY[2] {6225}
00:15:00.916|039| A165 OK Success
00:15:01.916|01D| A166 UID FETCH 7603 (BODY.PEEK[TEXT])
00:15:01.966|039| * 8 FETCH (UID 7603 MODSEQ (418646) BODY[TEXT] {1805}
00:15:01.976|039| A166 OK Success
00:15:04.976|03B| A167 IDLE
00:15:04.996|039| + idling
00:15:39.999|039| * 41 EXISTS

Tuesday morning, and now my other Gmail account is stuck on the swirly circle and won’t sync.

Seems I have to give up on this.

Edit: Both of them are stuck and not downloading the bodies of new email that they managed to sync the headers for earlier.

Looks like my Yahoo account (also IMAP) is also stuck.

Hi, I am sorry for delayed answer, anyway how often do you try to synchronize your Gmail account? They have quite strict synchronization limit.

Anyway I will need your IMAP logs, go to tools - settings - advanced, check IMAP under your account, apply and restart eM Client.

Simulate steps that leads to your issue and after that send logs… to galis@emclient.com together with this topic’s URL in subject.

then you can turn logging off.

regards
Jan

Yep, it’s become obvious that eM Client has been prematurely released for Gmail. Don’t know what the other mail hosts are like.

This is a very old thread, and much has changed since then. As I commented on your other post, eM Client is well tuned for GMail, so there should not be any problems.

eM Client works well with all mail hosts. Sometime there are a few problems, but that can usually be addresses by making sure the correct settings for that host are being used, Other times it is simply a misunderstanding of how eM Client works.