Getting weird characters in emails using Helvetica

Has anyone else gotten strange characters when someone sends an email that’s using Helvetica? I’ve attached a screenshot to show you what I mean. I tried reinstalling all of the Helvetica fonts, but that didn’t fix the issue. The cross symbols and the weird-looking i symbols at the bottom are showing up in any emails I receive that are using Helvetica.

I looked at these emails using a web client and the symbols don’t appear (the _i _symbols at the bottom are bullets •).

Any suggestions?


Helvetica is a font that is not available for free.
     When did you purchase it? perhaps there is an updated Version available?

Which Type of the Font do you have installed?
     a Postscript-Version? a TrueType-Version or an OpenType-Version?

What do Prints of these Messages look like? same Errors on paper?
     What type of Printer? a Printer with Postscipt in the Firmware/RIP?

What does it look like, when you write a message with Helvatica-Font?
     What does it look like, when sending such a “Helvativa”-message to yourself?

What does it look like when you use your Helvatica-Font in other Applications?

What does it look like when you Copy-Paste the body of the “broken” Message into another Application that does handle and display the Helvatica-Font properly…(e.g. “Word”)? Are the Errors also shown in Word?


Hello Fritz,

Thanks for the reply. I don’t remember when I purchased the font. I have a folder full of fonts I’ve purchased over the years. It’s a true type font. I have no idea if there’s an updated version available as I don’t recall where I purchased it. It’s always worked fine in the past. 

When I print the emails the strange characters remain. I have an Epson Artisan 837 printer. Not sure about Postscript in the firmware.

When typing a message, if I choose Helvetica Neue font, the little † symbol shows up every time I make a space, until I type another character. So, if I were to leave a space at the end of a sentence, without typing another character, it leaves the symbol. It looks like it’s only doing it with the Helvetica Neue font and not the other Helvetica fonts.

Other applications have no problems with the Helvetica Neue font.

If I copy/paste into another application such as Word or Wordpad, the text looks fine; no weird characters.


Okay, I just deleted the Helvetica Neue font and now it’s defaulting to just using Helvetica instead and everything looks normal. Not sure why Helvetica Neue font is showing those symbols in eM Client, but this is an acceptable solution.

Hi Shaun,

My idea to “check for an Update of the font” originated from my observation of freeware-Fonts that are updated every now and then.

this might also be interesting for you:

I you are a Grafix/Arts/… Professional I would suggest to buy Type1 (=Postscript) Fonts if the final Product will be printed later or OpenType -Fonts which tries to combine both the smooth and precise Screen-Display and Quality-Printing.  Just my 2 cents…