Forwarding within email accounts

I have 2 accounts in my mail - I’ll call them “[email protected]” and [email protected]".

I use Master as my principal account.

Any email received from external accounts into Master is Forwarded by default from [email protected] (not surprisingly).

However, any email received from Spare into Master is Forwarded (from within Master) by default from [email protected] and I have to remember to change the sender manually.

Is this by design or can I fix this in settings?

Hi Andy, not completely sure what you’re referring, but I believe you need to setup your spare account as an alias to your master account.\
To do so, please go to Tools > Accounts > Your master account > Aliases.

Hope this helps,

Thanks Paul. If I understand it correctly, an email alias is designed such that an email sent to Spare would automatically be redirected to Master. However this is not my issue.

Probably best if I give more specific detail!

Our family PC has eM Client with 2 email accounts which I’ll now call “Father” and “Mother”. My scenario is:

  • Mother sends an email to Father (we do talk to each other as well!) 
  • Father selects Forward email externally to (say) “Son”
  • Default account for Forward is Mother account even though this function is done within Father account
  • Son thinks forwarded email is from Mother not Father
    This is not a big deal. It just struck me as rather odd.

The simplest solution may be to remember to manually change the account when forwarding such emails.

Hi again Andy, sorry for my belated reply, this is definitely odd, eM Client should use the sender’s address as “To” automatically, are you able to replicate this issue, or create a screenshot when it occurs?

Are you having this issue while using multiple account in a single instance of eM Client or are you able to replicate the issue between multiple computers as well.

Thank you,

I’ve done some screenshots. Please let me know how to send them to you privately.

Hi again, it would be great if you could post them here on the forum, it helps us keep things organized and might help other users in the future to resolve a similar issue, but if you have privacy concerns, please submit the logs to my email, [email protected] with a reference link to this forum topic.

Thank you,

Thanks Paul. My screenshots show both names and email addresses so I have sent them by email.

I’ve just noticed that there is an option Tools>Accounts>Set as default. I can’t tell which account (if either) has been set but wonder if setting “Father” as default will solve the problem.

I set “Father” as default.

I then received an email from “Friend” addressed to “Father”, “Mother” and others.
From within “Father”, I selected Reply All. This still defaulted to From “Mother”.

So, no change.

Hi again Andy, sorry for my belated reply, are you using smart folders while trying to forward the messages, or are you focused on the account folder that the message was received to?
e.g. if the message was received by “father” and you wanted to forward to “mother”, have you been focused in father’s inbox or mother’s inbox or in the smart folders?

Can you please send me an exported message that was forwarded incorrectly, to submit the message to me, right click the forwarded message in your sent folder and select Forward > As attachment.

Thank you,

Hi Paul
I’ve sent you an email as requested.

I notice this has still not been resolved (as the problem just happened again!).

I’ve noticed that in ToolsAndy

Yes by clicking on default the account that your focused on in the account settings should be selected as the default account, the change should be indicated by bold text of the account in the left pane of the account settings.

Are you having issues with this? What version of eM Client are you currently using on your computer?

Thanks. I hadn’t noticed the bold text. It is quite subtle!

I’ve checked and mine is the default (bold) account. The problem remains. 

I’m using version 6.0.22344.0

So if your current account (Account A) is selected as default, when selecting Account B in your left pane and using the option “Set as default”, the bold text won’t change and account A stays selected? Or what exactly doesn’t start using the second account as default?

Note that the default account only controls a couple of things, default account would be assigned as the from address when using external mailto links, but mostly replies and new messages are selecting the account which received the message or based on the folder you’re focused on.

No, The default works fine. I hadn’t spotted the bold thing. I thought it might be an issue but now I’m not so sure!

I run Accounts A & B on emC.
Account A is the selected (bold) default.
If I (from within Account A) reply to an email sent to both Accounts A & B, it defaults as a reply from Account B.

This causes a lot of confusion!

As I previously suggested the From address is automatically selected from the folder you’ve received your email to, e.g. if you have inboxes for Account A and B, and you’re focused in Account A inbox, the reply from address should be selected based on the folder focus.

Account B should only be selected if the address was setup as an alias to the account in which folder you’re now focused on, are you having issues with this? Can you perhaps make a screenshot of the issue?

Hi Paul
As far as I can tell, when I’m focused on Account A the reply defaults as sent from Account B. I’ve sent you an email as requested with screenshots to demonstrate.

I’m not aware of ever using aliases. How can I check this?

For anyone following this topic, it seems like the issue has been caused by using an Alias for the account that has been causing the discussed issue. If anyone experiences a similar issue, please make sure no Alias is setup for the account in Tools > Accounts > Your account > Alias.

Otherwise this would be an expected behavior of the issue while using the second account as an alias to the first account.

Thank you.