Forwarding mail with attachment causes error

Occasionally when trying to forward a mail with an attachment I get the little red triangle and “An error occurred (IMAP) Message temporarily unavailable”.
The message goes into the sent box but the red triangle never goes away. (The message is actually sent OK and recipient receives attachment OK).
The only way for me to get rid of the red triangle is to delete the sent message!

Error log shows:
[IMAP] MailClient.Storage.Application.ItemOperationException: Message temporarily unavailable
GUIStatus_Exception_Reported = True

This is very annoying. I have checked for latest software and tried the repair function. Any help would be appreciated.

As you have already tried the repair option and made no difference and already checked for updates, could be you may have possibly some sort of corruption in your local mail database.

Suggest to first manually backup eM Client via “Menu / Backup”. Click the dropdown arrow on the right of “Refresh” and click show operations to see when the backup is completed.

Then remove your IMAP account and re-add as new. Hopefully that will then fix the issue.

Note: When you re-add your account, eM Client will take time to read all your emails again due to it has to recache them locally.

Thanks cyberzork - I will try that when I have a bit of time.

I was doing a few tests, I have 2 IMAP email on eM client and have been sending mail between these 2 emails. If I send a mail with an attachment, then no problem. If I then forward the mail with the attachment then I get the above mentioned error.

lunes 01 octubre 2021 :: 0840hrs (UTC +01:00)

Hi @davec

When you first send with an attachment, is the attachment local?
Same as you first send was OK, however, I found that when forwarding as you describe that I also had this error unless I re-attached the attachment locally.
Problem no more.

¡Saludos desde la soleada Jerez de la Frontera en España!
¡Mis mejores deseos y mantente a salvo!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Hi skybat,
Yes, that does work.

So I hit “forward”, save the attachment to desktop, delete the attachment from the mail, and then attach the attachment from the desktop.

Would be nice though if eM Client would fix the problem !

I am hoping a Support Engineer will read this. It’s really quite an annoyance. I just replied to an email that had a picture embedded in the text and I guess eM Client sees that as an attachment. I get the error message again, and even if I delete the error it comes back next time I start eM Client.
The only way to stop the error is to delete the message from the sent box.

Just tried alternate imap and smtp settings for my ISP - no improvement.
Tried turning off firewall and antivirus (Norton) - no improvement.

Anyone has other suggestions ??

So I hit “forward”, save the attachment to desktop, delete the attachment from the mail, and then attach the attachment from the desktop.

You shouldn’t normally ever have to re-save an attachment locally & re-attach just to forward. I personally cannot replicate that issue with any of my IMAP accounts using eM Client V 6,7 or 8 and have never done that with any other mail client.

If you are an eM Client Paid Pro customer, I would submit a support ticket for that problem. You will probably need to send through eg: eM Client Log files etc to be investigated.

Unfortunately I do not have Pro account and it’s difficult to justify CAN$75 for an email program when so many are free. (I will wait and hope they have a sale!)
I just discovered another interesting fact. I have tried another computer running eM Client with the same ISP - I see the same problem - however this setup was set to not empty the trash when closing the client. So the error message returns even if the fowarded mail was in the trash, and will not clear until the trash is emptied !!??

Did a bit more testing. Forwarding mail with attachment gives the error as described above. I then right click “sent” box, properties, repair. This actually deleted the sent item ! (and then of course no more error).
So eM Client thinks there is something corrupt about a forwarded message with an attachment.

Also, I installed eM Client on a friends computer a couple of weeks ago. Everything was working fine, except today she tells me she’s seeing this exact same error message pop up every time she starts the client. She clicks “ignore” and it goes away until the next time the client is started. She’s not tech savvy and wants me to go over there to “fix” it - I think I will have to install an alternate email program.

Just discovered this error also occurs if just replying to a mail that has some kind of attachment, such as a picture in the body of the mail.
Surely I cannot be the only one getting these errors (well me and skybat above).