Font Sizes For Replies with Signatures Always Changes to Default 12 pt


I found an issue with the way signature replies are handled in eM Client.

Currently, all of my font settings are set to Calbri size 10 pt.  This goes for Read, Compose, Reply, New Template, Forward, Default Message Size, etc. (basically every font setting available in the Settings menu).

If I create a new email and send it, the font is correct.

If I reply to an email, the font size of the signature is correct, but the font size within the email of the replied text always switches to 12 pt.

I also noticed that when I try to edit a signature template, the font size in the title bar is at 12 pt.  When I click on anywhere within my signature, the font size is set to 10 pt.  Selecting all the text, setting to 10 pt, saving, hitting apply, closing the setting menu, then reopening the signature template still shows the initial font setting at 12 pt.

I think there may be a bug that is reverting back to a pre-determined size of 12 pt which is overriding the font size of my replies.

Is there any setting that I am missing?  I am using the latest version 6.0.21372.0 and I have adjusted the following:

Mail --> Read --> Preferred Font Size for Messages = 10 pt
Mail --> Compose --> Preferred Font Size for Messages = 10 pt
Mail --> Templates and Signatures --> Mail Templates --> Default size used in template = 10 pt

Again, if I open up one of my signatures, by default, the font size is at 12 pt even though all the font sizes are set to 10 within the signature (verified with select all and changing to 10 pt repeatedly).

Also, I have noticed that any fonts surrounding my images within my signatures are always at Segoe UI 12 pt.  Don’t know if this is a related issue.

Please help with any recommendations.



I have also just noticed that in the source of the HTML of a replied message, there isn’t a “< div >” style assigned to the main text of the email (the div style is just blank), which is probably the problem why the font is incorrect for everything above the signature (too large).

Hi Brennan, can you please make a couple of screenshots of this issue, I’m not completely sure what you’re referring to.
Also please check the version number of eM Client that you have currently installed on your computer? You should be able to find the exact version number in Help > About.

Thank you,

Hi Paul,

I am currently using the latest version of eM Client (6.0.21372.0).

Here is a screen shot of the initial message, which is using a Mail Template, then a reply using a Signature Template.  The body of the email is not formatted to Calbri 10 pt.  I also have the code of the reply message with a section highlighted showing that the “< div >” style is not being assigned to the body of the email.

These are screen shots of the emails through the webserver.  In eM Client, it looks fine though.  My concern is how the email is being displayed to the rest of the world.

As I stated above, I have changed all the settings that I can find to set all of my fonts to Calbri 10 pt.  The problem is when I reply, it does not transfer the formatting for the body of the email.

Please let me know if you need further details.



Hi again Brennan, unfortunately I’m afraid this might be an issue of your webmail application rather than eM Client. I’m unfortunately unable to support issues with the webmail application, as your webmail may be dropping the formatting on the message and can use default formatting for all messages, this is not that uncommon with some webmail tools.


I don’t think its a webmail client issue because when I receive a reply from an email that I have already replied to in eM Client, this incorrect formatting occurs.

Like I mentioned earlier in my original post, if I open up the signature template window and I don’t click on anything, the font in the title bar of the signature template window is set at 12 pt, even though its been confirmed multiple times that the font throughout my entire signature is 10 pt, as well as the default compose font is 10 pt too.


I just solved the issue.  This incorrect formatting occurs when you use the Signature Template option.   If you only use the Mail Template option for New Mail, Replies and Forwards, this issue does not occur.

Might be a good idea to remove the Signature Template option, as this doesn’t really serve a purpose if the Mail Template option does the exact same thing.

Thanks for your help anyways.

Hi Brennan, glad it works, please make sure to let us know if the issue reoccurs or if you come across any other issues or questions about the application, we’ll be happy to help.

Signatures and Templates are a different feature, as signature can be imported at any time, templates define the style for the whole message on your reply, e.g. if you receive a message with a set formatting, replying using a template will reformat the message, signature will be added and adjusts to the existing formatting.

However we’re considering some improvements for future releases, thank you for your feedback regarding this option.


The reply template does not load when replying to txt messages.

I’m unfortunately unable to replicate the issue, HTML formatted template loads each time when replying to a plain text message while my default reply formatting is set to HTML and the reply template is selected for replies using my account.

Can you please make a screenshot of your settings in Tools > Settings > Mail > Compose / Replies and Forwards and submit the screenshots to us here on the forum?

Thank you,

We have this problem all the time — mail template is not a real substitute for the signature, however.  The only option that seems to work for us is setting all mail to format as plaintext, which clears out all of the formatting garbage.  Before, hitting send you can change the formatting to HTML and then insert the signature.  Further email editing after this can alter the formatting.  This can happen whether it is a new or replied message, and the signature was typed into the signature window, not pasted.
It’s a rather annoying issue, and a poorly formatted email is second only to misspelling, in business email, so it would be a deal-breaker for many users.
In Outlook, there is a setting to override all other formatting with your choice of font size/colour/etc. — it ought to be a straight-forward matter to add that feature and eliminate this persistent issue for good.

This is unfortunately due to different formatting of the incoming message from the sender. The sender might be using a different application that includes a different default line spacing in their message/reply - you can use the remove formatting tool in the compose tools to use your default formatting.