Folder exclamation mark

Hi. I have a problem with a exclamation mark on one of my folders (see picture)

I cant get rid of it when I press “Ignore”, it always comes back when I open the email program. Please help me on this one.
Thanks
Gus

This is usually a server sided problem but send us your IMAP log so we can analyze it in more detail.

Hi, here it comes:

15:47:53 Online state: changed to online with reason NetworkAvailability
15:47:53 Gmail [IMAP] Synchronizing subfolders: For folder Gmail/
15:47:53 Gmail [GData] Synchronizing folder list
15:47:55 Gmail [GData] Synchronizing folder ‘Gmail/Contacts/’
15:47:55 Gmail [IMAP] MailExceptions.OperationException: Unable to create folder “Gmail/Junk E-mail/” on the server. ([ALREADYEXISTS] Duplicate folder name (Failure))
15:47:56 Gmail [GData] Synchronizing folder list
15:47:56 Gmail [IMAP] Synchronizing subfolders: Done
15:47:56 Gmail [IMAP] Synchronizing subfolders: For folder Gmail/Inbox
15:47:56 Gmail [IMAP] Synchronizing subfolders: Done
15:47:56 Gmail [IMAP] Synchronizing subfolders: For folder Gmail/[Gmail]
15:47:56 Gmail [GData] Synchronizing folder list
15:47:57 Gmail [IMAP] Synchronizing subfolders: Done
15:47:57 Gmail [IMAP] Synchronizing subfolders: For folder Gmail/Junk E-mail
15:47:57 Gmail [IMAP] Synchronizing subfolders: Done
15:47:57 Gmail [IMAP] Synchronizing messages: For folder Gmail/Inbox
15:47:57 Gmail [IMAP] Synchronizing messages: For folder Gmail/Inbox
15:47:58 Gmail [IMAP] Synchronizing messages: Done
15:47:59 Gmail [IMAP] Downloading message part…
15:48:00 Gmail [IMAP] Downloading message part…: Done
15:48:00 Gmail [IMAP] Downloading message part…
15:48:00 Gmail [IMAP] Downloading message part…: Done
15:48:02 Gmail [IMAP] Synchronizing message flags: For folder Gmail/Inbox
15:48:02 Gmail [IMAP] Synchronizing message flags: Done

This happens when you have disabled showing of the Junk folder in IMAP in Gmail settings. eM Client does not see the folder so it tries to create it which results in this error message. Please enable showing of the Junk E-mail folder in IMAP and let me know if it helps.

Hi. It worked. Thank you for your help.
Gus

Seem to have the same problem. This is not Gmail but a normal IMAP account.

Hello, seems like you have two folder named equally, please make sure to keep one Sent folder only, as it is not allowed to keep two mailboxes using the same name on the same server, or one of the folders is not correctly named, right click the sent folder and select Properties, I believe it’s server location or name might be empty, in that case please try to remove the folder using Shift+Delete but clear it of all contents before you do so…

I first had only the Inbox on the webclient and eM Client. Then I deleted a message in the folder on eM Client and then it automatically created the Sent folder to put the message in.

I tried to solve it by creating a Sent folder on the webclient but didn’t work (I miss graphical emoticons on this editor )-:

With Delete button on kb I get: “Cannot delete special folders”. Shift+Delete does nothing.

Please check your default folder settings in the account settings under Tools > Accounts > Your account > IMAP, and make sure the correct Sent folder is linked as the special folder. Remove the other folder from your list. The error suggest one of the folders is not correctly named, as I suggested you can check the actual server name of the folder in Properties of the folder. Note the name of the folder can’t include any empty characters at the end or invalid characters.

Make sure to rename the folder properly or remove it.

Let me know if the issue persists.

Well, I did this:

Then Sent folder is gone. But now I have a second Drafts folder:

Properties for the erroneous Drafts folder:
Name: Drafts
Location: cheapingz/Drafts
Server location:                          [this line is empty]
Type : Mail

Properties for the Drafts folder:
Name: Drafts
Location: cheapingz/Drafts.
Server location: Drafts                       
Type : Mail

After my last message I created the other folders (Drafts&Trash) to have a “normal” account.
Please note that I cannot delete this folder, both Delete and Shift+Delete do nothing.

Trying to solve things I’ve put all the folders in the Special folders. Here are the errors:

20:16:23 cheapingz [IMAP]  MailExceptions.OperationException: Unable to create folder “cheapingz//” on the server. ([CANNOT] Invalid mailbox name: Name is empty)
20:16:23 cheapingz [IMAP]  MailExceptions.OperationException: Unable to create folder “cheapingz//Drafts/” on the server. ([CANNOT] Invalid mailbox name: Name must not have ‘/’ characters)
20:19:03 cheapingz [IMAP]  MailExceptions.OperationException: Unable to create folder “cheapingz//” on the server. ([CANNOT] Invalid mailbox name: Name is empty)
20:19:03 cheapingz [IMAP]  MailExceptions.OperationException: Unable to create folder “cheapingz//Drafts/” on the server. ([CANNOT] Invalid mailbox name: Name must not have ‘/’ characters)
20:25:53 cheapingz [IMAP]  MailExceptions.OperationException: Unable to create folder “cheapingz//” on the server. ([CANNOT] Invalid mailbox name: Name is empty)
20:25:53 cheapingz [IMAP]  MailExceptions.OperationException: Unable to create folder “cheapingz//Drafts/” on the server. ([CANNOT] Invalid mailbox name: Name must not have ‘/’ characters)

Now I have a second Drafts folder under a folder with no name.

Seems difficult to solve this. For some reason things go haywire. I will delete the IMAP account and start over :slight_smile:

Try using the Automatically Detect Special Folder Names option, if you haven’t already.

  • Merg

I previously tried that option aswell, but in the situation above it didn’t solve anything.

Now I have deleted the account and made a new one. Things seem to be OK now. In the account settings the Automatically detect special folder names option seems to be ticked by default.

Yeah, sometimes if it loses the Special Folders it is hard to get them back again correctly. It should detect them automatically. The manual entry is for the case when your Special Folders have unique names like “Garbage” for the Trash folder or you want it to use a specific folder for the Special Folder.

  • Merg

Filling out the special folder names or setup to auto-detect the special folders should help the problem, if you’re still having issues with this please navigate to Tools > Settings > Advanced and enable IMAP logging for the problematic account,

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    Once the error reoccurs, please go back to the advanced settings window and submit the logs to us using the “send logs” button, please include my work email as a copy , mcgregor@emclient.com and include a reference (url) link to this forum topic.