Focus of Search Box (top right)

Version 9.0.231 (b25143a) surprised me very pleasantly with a felicitous search dialog in the upper right corner when I press CTRL F now.

However, the focus remains in the main window, therefore calling it with the keyboard is useless: I still have to reach for the mouse and click on the dialog to fill it in.

Is there anything against setting the input focus to the first field after opening the dialog?

The default shortcut is Ctrl + E.

If you use that, the cursor is automatically focused in the search box.

If that is not happening, please send an email to testing@emclient.com

Nope. I am using Windows 10. STRG E → nothing happens.

STRG F opens search dialog – no field focused, but TAB focusses elements in main window.

Pressing Ctrl + E keys on V9 Beta 9.0.231 (does focus the search cursor) automatically for me in the “top right corner search field” as you say @Gary. Currently using Windows 11. Win 10 should be the same.

sábado 08 enero 2022 :: 0729hrs (UTC +01:00)

Can confirm that BOTH Windows 10 & 11 with either v8.* or v9 Beta will put focus to
search box using Ctrl + E as presumed by @cyberzork

¡Saludos desde la soleada Sevilla España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

1 Like

This is my reality:


Windows 10 x64 Version 21H2
Intel i7-11700, 64 GB

What is your desktop resolution and scaling?

No idea what this has to deal with a shortcut triggering a dialog, but native solution is 4K (3840x2160), Scaling is 125%.

Can you please set the scaling to 100% and see if the cursor is in the search box when you use Ctrl + E

Because STRG E does not trigger the dialog to open, this is pointless.
Setting scale to 100% and triggering the dialog with STRG F ends up with the same result as shown above.

Pressing Ctrl & E is not mean’t to open the popout “Search Dialogue Box” as well, and currently only puts the cursor automatically in the "Search Field " at the top right corner when you press Ctrl & E.

Are you wanting Ctrl & E to also open the search dialogue box and put the cursor in the top of that search dialogue box instead ? Seems like you want to do more than its programmed to do.

STRG E doesn’t trigger anything in my installation.

My target is opening the search dialog (usually in all windows programs with STRG F) and have the first field (of this just opened dialog) focused (as usual in other windows programs).

This should not that challenging because other dialogs of emClient can do this quite well.

Check in eM Client Settings (Shortcuts) that Ctrl+E has not been changed from the default.

Note:- If the poput “Search Dialogue Box” is already open Ctrl & E key won’t work. So make sure (before pressing Ctrl & E keys) that you are in either the eg: Inbox, Sent box, Subject, Body etc of an email and no compose windows or popup boxes open anywhere.

What does this change?

It changes STRG F to STRG E but the behaviour is still the same: STRG E opens the dialog but dialog has no focused field. (tested)

Sorry, but this hint is useless.

Update:
It should not matter from where I open the search dialog. When it opens with the shortcut, a field should be focused so that the dialog is operable with TAB. This is the Windows standard.

Well, I said Ctrl + E, but anyway . . . .

There are some issues in the beta when if the scaling is anything but 100% the cursor may not show up in some places. Like if you start a new message, the cursor is not in the To: field.

Can you reset all the shortcuts to default, and see if it works. There is an option in Menu > Settings > General > Shortcuts to reset them all.

To be clear:
It does not matter, which shortcut is used, if it can be changed in the settings (as you described). I changed it to STRG E, but it did not change anything – as I expected because it only changes the trigger key but not the behavior.

The scaling as well should not interfere the behavior of a dialog focus. These two things have nothing to do with each other - otherwise that would call into question my principles of programming, which I have been using successfully for over 30 years.

Did you reset the shortcuts as I suggested?

Actually, in the beta there is a bug that does affect this.

May I suggest, if you are testing the beta, please send your comments to testing@emclient.com rather than posting them here.

Actually, in the beta there is a bug that does affect this.

Hard to believe. Because this requires code to achieve this, and this code should be easily be found.

May I suggest, if you are testing the beta, please send your comments to testing@emclient.com rather than posting them here.

I notified this in the very first comment of my “feature request”, that it is the currently available beta (version number). Therefore, this should have been the only answer instead of discussing with me additionally about a – configurable – keyboard shortcut. This led into the wrong direction.

Anyway. I will notify this thread to this address.

domingo 09 enero 2022 :: 1059hrs (UTC +01:00)

Hi @NoSi1

I made an earlier post on this thread and have since read the thread again more times.

I did not understand some of the words you use so I searched for a meaning to be clear,
we have an expression in Spanish to explain this, there is no direct translation to English,
but I now understand and comprehend.
I think some of the things you say should best be described as ‘in your opinion’, that
is fine though you do not as far as I am aware have in depth knowledge of the way
that eMC has been written.
Your issue is with eMC v9 Beta did you previously use eMC v8.* and if so were the same
issues there?
Is your installation of eMC a clean install and not an upgrade?
It has not been said so I will say - Clearly you use a German keyboard, though is your OS
in the German language by default or a translation?

I am surprised that if as you suggest there is a ‘bug’ in eMC, this could be the case,
I wonder why there have not been multiple posts about this particular issue.
There have been a number of posts on this issue, none replicate your issue.

I am retired but able to get computer issues tested, my company has several offices
throughout Europe including one in Vienna.

I asked for tests to be run with eMC 9.0.231.0 Beta running on Windows 10 x64 21H2
on four separate machines - NONE were able to replicate your issue.
Three of the machines have a variety of other software installed and one was to a
a clean OS install and eMC only.

I have no reason to doubt what you say, but clearly there is something within your
computer setup/software installation that is causing this issue.
As you should know with 30 year experience programming, ALL software contains bugs
(on a random date & time with an early high tide in mid winter)

As @Gary says you should direct your issues to testing@emclient.com

¡Saludos desde la soleada Sevilla en España!
¡Mis mejores deseos y mantente a salvo!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.