Flickering when using Dark Mode

I use Dark Theme which came with eM Client (Windows 10). When I switch between emails, part of layout which displays email body (on bottom square) flickers white before it goes to dark to match the theme. This is painful on the eyes as I do this 50-100 times per day and this flickering is very hurtful. Any ideas how to stop it?

viernes 10 diciembre 2021 :: 1957hrs (UTC +01:00)

Hi @stever1717

When did this start?
What version of eMC are you using?
What is the spec of your computer?
How much RAM?
HDD or SSD?

¥Saludos desde la soleada Sevilla en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Hello @skybat! Started when I switched to Dark Mode theme. Latest EM Client on windows 10 64 bit, plenty of RAM and free space on SSD

@stever1717,

I agree however to me it is more of a ‘flash’ in different parts of the screen as it transitions from a light to dark display.

@skybat

Not sure when this started to happen but it appears to me to be getting worse (could be due to aging eyesight).
I initially thought it was a Windows issue, but not seeing this with any other apps.
I am running latest version of eMC, Windows 10, HDD, Ram=8gb.

viernes 10 diciembre 2021 :: 2208hrs (UTC +01:00)

Hi @sunriseal

Obviously I have knowledge of your eyesight, however, unless your eyesight is very bad
it is unlikely and you would probably see flashing elsewhere.
To eliminate, do you have flashing in any other theme?
Also I suggest that an upgrade to an SSD should help the situation particularly
if it is getting worse.
I also use a Dark theme that I edited myself and have never had any issues,
if you would like a copy to try, ask and I will give you a link to download.

¥Saludos desde la soleada Sevilla en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

viernes 10 diciembre 2021 :: 2208hrs (UTC +01:00)

Hi @stever1717

To eliminate, do you have flashing in any other theme?
I also use a Dark theme that I edited myself and have never had any issues,
if you would like a copy to try, ask and I will give you a link to download.

¥Saludos desde la soleada Sevilla en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

When I switch between emails, part of layout which displays email body (on bottom square) flickers white before it goes to dark to match the theme

Yes “I can also replicate this issue”, which mainly appears very noticeable in email bodies with “hardly any text or inline pictures” on the email using the (default dark theme).

Eg: If you click on an email while using the default dark theme with say (only a few lines of text at the top) and (nothing else in the email), then look closely to the body of the email just after you click the subject you will see see a slight “flicker / shimmer” in the (body background) as @sunriseal advised. This is also alot more noticable when using (View Layout) “Messages on Right”.

I haven’t ever noticed that before as my emails usually have alot of text and inline pictures pages long. and haven’t noticed if its been there in previous eM Client versions. Currently using EMC V 8.2.1659.

You do?

I tried YOUR theme and it does flash
when loading as it does with the default Dark theme.

Tried a few of the others and no flashing

I am guessing it’s a simple coding bug where window colors briefly change to default OS (Windows) setting.

viernes 10 diciembre 2021 :: 2246hrs (UTC +01:00)

Hi @sunriseal

Sorry, I do not remember who uses my dark theme, there have been nearly 5000 downloads.

I have absolutely no flashing at any time so I have to conclude that it is related to computer
performance. I have:

Lenovo Thinkpad P17 Gen 1
Intel Xeon W-10885M vPro Processor
(2.40GHz, up to 5.30GHz with Turbo Boost, 8 Cores, 16MB Cache)
Win 10 Pro Workstation x64 21H2
64GB(16x4) DDR4 2933MHz ECC SoDIMM
512GB SSD, M.2 2280. PCle-NVMe, OPAL2.0,TLC (X4)
17.3" UHD (3840x2160) IPS Anti Glare 500nits Non-Touch
NVIDIA Quadro RTX 5000 16GB GDDR6 256bits

So maybe this is why I do not have any performance or display issues.

Sorry I can not help anymore.

¥Saludos desde la soleada Sevilla en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Wow, not sure what provoked that response. I don’t believe I said anything other than indicating that I had already tried your theme (not complaining that you should know I had).

OK, moving right along
 appreciate your taking the time to respond.

1 Like

Its nothing to do with computer performance. This flicker / shimmer (for a split second) is definately there as initally @stever1717 and @sunriseal later pointed out. I can replicate this on two differant highend spec Win 10 pc’s using the default “Dark Theme”. You have to look closely to see it happen.

If its not a coding bug as @stever1717 suggested above, then it could just be the way the Dark Theme transition works when it reads the HTML email body and displays the background. Would need someone from the Devs to advise on that.

1 Like

sĂĄbado 11 diciembre 2021 :: 0832hrs (UTC +01:00)

Hi @sunriseal

There was no intention to offend or upset.
Perhaps my use of your language is too direct.
Even though I use English I prefer Spanish and
grew up tri-lingual, Spanish, Portuguese & English
I am happy to use any of them as required.

ÂĄBuena suerte!
¥Saludos desde la soleada Sevilla en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

sĂĄbado 11 diciembre 2021 :: 0833hrs (UTC +01:00)

Hi @cyberzork

Whether it is or is not computer performance related for me is academic,
I have never noticed any flashing or odd effects.
Also, as you say ’ You have to look closely to see it happen’,
is it really worth the bother?

ÂĄBuena suerte!
¥Saludos desde la soleada Sevilla en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

@skybat

is it really worth the bother?

No it’s probably not worth fixing at this present time, unless we start to get alot of peeps who are also noticing this issue & are not happy.

Got it
 I can surely handle “direct” but was taken back by your interpretation of what I said. Time to move on and concentrate on our “passion”, problem solving :wink: