File Explorer "Send To" option no longer works with EM Client

I have EM Client installed on 2 PCs, both with Windows 10. One of these allows me to use the file explorer “Send To Mail Recipient” functionality perfectly, but the other, my main laptop, will not let me do this no matter what I try. When trying to use the Send To Mail Recipient menu item i get the generic message saying that there is no suitable client installed.
I have ensured that the default mail client is EM Client and I have set the MAPI Send EMail command default to EM Client, but this does not work.
I have installed the EM Client 7 beta over version 6, but this did not work.
If I install Thunderbird, this functionality works flawlessly with that. Setting the default back to EM Client does not make it work.
If I had to guess what’s changed it’s possible that this has stopped working since I installed Outlook 2016 as part of Office 365.
I have checked in the registry, in HKLM\Software\Clients\Mail and the default value is set to eM Client.
I use this functionality a lot, so really need it to work.

You might check the default apps advanced settings (choose default apps by filetype) in Windows 10 and make sure .mapimail is set to eM Client.

I also have a shortcut in my Send To folder for eM Client.
Go to the Send To folder:

Open the folder. Create a shortcut therein that points to:

Name it “Mail Recipient”. 
Test it with right clicking any item and the Send To -->Mail Recipient right-click option. This should open an eM Client new message window with the item you right clicked selected as an attachment.

To change the Email button function in Windows Explorer you are going to have to deal with registry settings in this key:


Will involve changing the Class IDs shown therein to match eM Client. Much too complicated for the average user, especially when the shortcut method above will do just fine.


I had already checked the .mapimail setting, and it was set to em client.

Creating the shortcut has worked, although you might want to correct your post so that the shortcut points to the em client exe rather than it’s own folder.

Any idea why it suddenly stopped working?

I can assure you that I have extensive experience and regularly make registry changes, so I’d be grateful if you could let me have details of the changes that you mentioned to make the windows explorer email button functionality work.

Change the above:
Open the folder. Create a shortcut therein that points to:

To read:
Open the folder. Create a shortcut therein that points to:
“C:\Program Files (x86)\eM Client\MailClient.exe”

Thanks, I made a comment noting a correction to my shorcut item above.

I have not investigated the matter, but I think one would need to examine each and every the Class IDs in the registry key/subkey I noted above to determine what they are pointing to. From that, likely substituting the right eM Client’s Class ID should repair the issue.

Thanks for the advice! I created the shortcut, however, this only opens eM Client but does not open an email with the selected file attached. Did I miss something?

Mine works as I explained. Do you have eM Client set as your default email application?

Sure! All options activated.

Make sure you have the shortcut you created stored in each of the following folders:





Dear IsoQuantic, I don’t have the directories c:\Users\Default\SendTo or c:\Users\MyName\SendTo by default. Should I create these??

You can ignore those.

Assuming Windows 10, go to the folder below by substituting your personal username for the "YOUR_USER_NAME_HERE"  in this one below:


Delete any shortcut that relates to email in that folder.

Now open a new Explorer window and navigate to:
“C:\Program Files (x86)\eM Client\MailClient.exe”

Right click MailClient.exe and create a shortcut.

Place that shortcut in the location below then close all the open windows.

You should then be able to right click on a file on your computer and select Send to Mail recipient and it will open a new email window with the file attached.

Thanks! That did the trick for me. Most appreciated!