Fastmail Calendar SSL Problem

Hi,

I am trying to get EM Client to Sync my FastMail Calendar without much success, when I look at the CardDAV Log file I have the errors below error messages

According to FastMails Help, the following is required:
Server = https://caldav.messagingengine.com/

SSL/TLS Encryption = Yes (required)
Username = Your FastMail email address, including the domain
Password = Your FastMail password

I have the right account in Fastmail for this service and I use this without problems with Mail on OSX, so I can only assume I need to make some thought of setting change in EM.

Thanks,

Gavin,

12:42:08.507|022|   C: OptionsCommand https://caldav.messagingengine.com/
12:42:08.850|022|   S: OPTIONS https://caldav.messagingengine.com/
12:42:08.850|022|   NotFound Not Found
12:42:08.850|022|   Response, stream length:
-1, 162
12:42:08.850|022|   Content:

12:42:08.850|022|  

404 Not Found

12:42:08.850|022|  
12:42:08.850|022|  

404 Not Found

12:42:08.850|022|  


nginx

12:42:08.850|022|  
12:42:08.850|022|  
12:42:08.850|022|  
12:42:08.850|022|   C: PropfindCommand https://caldav.messagingengine.com/
12:42:08.850|022|   <?xml version="1.0" encoding="utf-8"?>
12:42:08.944|022|   S: PROPFIND https://caldav.messagingengine.com/
12:42:08.944|022|   NotFound Not Found
12:42:08.944|022|   Response, stream length:
-1, 162
12:42:08.944|022|   Content:

12:42:08.944|022|   404 Not Found

12:42:08.944|022|  
12:42:08.944|022|  

404 Not Found

12:42:08.944|022|  


nginx

12:42:08.944|022|  
12:42:08.944|022|  
12:42:08.944|022|  
12:42:08.944|022|   C: PrincipalMatchCommand https://caldav.messagingengine.com/
12:42:08.944|022|   <?xml version="1.0" encoding="utf-8"?>http://icewarp.com/ns/"; />http://icewarp.com/ns/"; />http://icewarp.com/ns/"; />
12:42:09.179|022|   S: REPORT https://caldav.messagingengine.com/
12:42:09.179|022|   NotFound Not Found
12:42:09.179|022|   Response, stream length:
-1, 162
12:42:09.179|022|   Content:

12:42:09.179|022|   404 Not Found

12:42:09.179|022|  
12:42:09.179|022|  

404 Not Found

12:42:09.179|022|  


nginx

12:42:09.179|022|  
12:42:09.179|022|  
12:42:09.179|022|  
12:42:09.179|022|   C: OptionsCommand https://caldav.messagingengine.com/
12:42:09.272|022|   S: OPTIONS https://caldav.messagingengine.com/
12:42:09.272|022|   NotFound Not Found
12:42:09.272|022|   Response, stream length:
-1, 162
12:42:09.272|022|   Content:

12:42:09.272|022|   404 Not Found

12:42:09.272|022|  
12:42:09.272|022|  

404 Not Found

12:42:09.272|022|  


nginx

12:42:09.272|022|  
12:42:09.272|022|  
12:42:09.272|022|  
12:42:09.272|022|   SynchronizeFoldersCommand executing on ( /ACCOUNT:5)
12:42:09.272|022|   C: PropfindCommand https://caldav.messagingengine.com/
12:42:09.272|022|   <?xml version="1.0" encoding="utf-8"?>http://calendarserver.org/ns/"; />http://apple.com/ns/ical/"; />
12:42:09.366|022|   S: PROPFIND https://caldav.messagingengine.com/
12:42:09.366|022|   NotFound Not Found
12:42:09.366|022|   Response, stream length:
-1, 162
12:42:09.366|022|   Content:

12:42:09.366|022|   404 Not Found

12:42:09.366|022|  
12:42:09.366|022|  

404 Not Found

12:42:09.366|022|  


nginx

12:42:09.366|022|  
12:42:09.366|022|  
12:42:09.366|022|  
12:42:09.366|022|   SynchronizeFoldersCommand finished on ( /ACCOUNT:5)

Hi Gavin, unfortunately it seems you’re using a wrong CalDAV URL, when you open the URL you’re using you should be able to login in the browser as well.
If I open the URL you’re using, I’m getting the 404 error, just as eM Client is.

Can you check with your calendar service for the correct caldav url? Did you use the automatic setup for this account?

Thank you,
Paul.

Thanks for the help, found that I have to use the address of https://caldav.messagingengine.com/dav/calendars/user/username@domain.tld/

No problem, glad I could help, let us know if you come across any other issues or questions, we’ll be happy to help.

Thank you,
Paul.