Failed to Upload Message

This is a terrific program but everytime I open it I get this message:
Failed to upload message (Named e-mail)

Message wasn’t uploaded to IMAP server because the folder “…” Doesn’t exist anymore

(Options) Create folder or Skip upload

I have tried clicking both options but it still returns on next opening.

I use G-Mail.

Thanks, Derek

I am afraid that you have only two possibilities:

  1. Delete the message which eM Client is trying to upload to deleted folder.
  2. Manually create the folder on the server via browser. Do not forget to use identical name “…”.

Having the same problem here on Gmail.

The folder DOES exist already.

It’s a bug in EM Client, works just fine in Outlook.

I believe it has to do with the parenthesis in the folder name, something GMail and a couple other IMAP servers support, just not most Windows based servers.

Send us your IMAP log. Go to Tools - Settings - Logging, check IMAP under the problematic account and restart eM Client. Wait until the error message appears and send us the log with a reference to this topic using the same logging settings window. Thank you.

Log file sent, after removing my plain text password that should never have been logged.

I was able to fix this by making sure the folder name was EXACTLY (case-sensitive) the way it was mentioned in eM Client. For example, I had a folder called “Nightly Stats” and eM Client said it was unable to upload to “Inbox/Nightly Stats”. When I logged into, the folder was actually called “INBOX/Nightly Stats”. I renamed this to “Inbox/Nightly Stats” and it worked perfectly fine.

ah, glad there’s a workaround until eM Client fixes their bug and starts using case sensitive folder names.


Thank you so much for this! Mine works now. That was SO aggravating!!!

Welp, the workaround didn’t help mine. I think the parenthesis are still causing problems.

I have tested it right now and the parentheses do not cause the problem. Please make sure that the name of the folder is identical.

I already did that, even if it wasn’t that’d be an eM Client issue for changing the name of the folder in the first place since it’s all handled automatically when the move action is performed.

This entire problem is a result of trying to move mail from the Inbox to an Inbox subfolder via eM Client.

I have the same issue as detailed above when attempting to move a message from the inbox to a subfolder of a IMAP gmail account in eM Client.

Renaming the folders manually in gmail is NOT an acceptable solution. Can an eM Client technician please comment and when this issue will be resolved within the software itself?


Meh, I switched to Thunderbird instead. I mean, when it comes down to it, I have 2 PCs I need a mail client on, at $50 a pop for eM Client with crappy support and lacking basic features I can spend $100 for just email, or I can buy MS Office Professional (Academic license) for $120 and use it on 3 PCs.

At the end of the day, eM Client is overpriced and underwhelming.